Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000184openvibe-pluginspatch submissionpublic2016-11-28 17:392016-12-08 14:26
Reportertoncho11 
Assigned Tojtlindgr 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOpenVibe 1.2OSOS Version
Summary0000184: Update to GTEC driver.
Description1) Code refactoring. Now there is a new class/struct "GDevice" and a collection "GDevices". This helped reduce the code.

2) Added a new functionality: a new checkbox in the config "Show device name". When checked this adds the ID (the serial) of the amplifier to the name of the channel. This is quite useful when using several amplifiers because the order of acquisition is not guaranteed currently. And there is no interface to set it.
TagsNo tags attached.
Attached Fileszip file icon new-gtec-driver.zip [^] (19,300 bytes) 2016-11-28 17:39
zip file icon new-gtec-driver_version2.zip [^] (115,065 bytes) 2016-12-02 13:38
zip file icon new-gtec-driver_version3.zip [^] (21,254 bytes) 2016-12-05 10:54

- Relationships

-  Notes
(0001227)
toncho11 (reporter)
2016-12-05 10:55

Version 3 adds small refinements.
(0001231)
jtlindgr (administrator)
2016-12-07 12:51

v3 with some mods integrated, latest related commit

git 740168c3890e568ef2995424ac0be90e0afcf881

Thanks for the patch!
(0001232)
toncho11 (reporter)
2016-12-07 18:18

Hi,

I think there is a bug. I can get the data only from 1 out of 3 amplifiers + 3 trigger channels. All amplifiers are detected but only 1 is transmitted to the Designer. I think the channel count is wrong. It should be 48 + 3, but it is 16 + 3.
(0001233)
toncho11 (reporter)
2016-12-08 11:04

Yes, it works. Good job!

I got confused ... so maybe another user might forget to increase the number of channels. Maybe it should be NumApplis * 17 by default when you install OV or this should not be changed at all.

Actually reducing the channels has not much sense because we are never sure from which amplifier we are going to remove channels. This is because we still do not have manual order. If we say 16 we do not know which amplifier.
(0001234)
jtlindgr (administrator)
2016-12-08 11:23

Are you sure the amps are not ordered based on the way they are chained by the sync cables? That would make sense, since the chain seems linear. In any case, how about I solve this by adding a warning if less than max number of channels have been selected in a multiamp case? One reason to not make the max number of channels mandatory is that it will make the impedance check slower for those users who only need fewer channels.
(0001235)
toncho11 (reporter)
2016-12-08 13:37
edited on: 2016-12-08 13:38

I do not use the impedance. We check the signal a little bit: blinking ... alpha ...

Both are OK for me (warning/48 by default).

(0001236)
jtlindgr (administrator)
2016-12-08 14:26

I pushed a mod with a new warning. I also lowered some log levels from warning to info, as they imo do not seem to be causes for alarm.

- Issue History
Date Modified Username Field Change
2016-11-28 17:39 toncho11 New Issue
2016-11-28 17:39 toncho11 File Added: new-gtec-driver.zip
2016-12-02 13:38 toncho11 File Added: new-gtec-driver_version2.zip
2016-12-05 10:54 toncho11 File Added: new-gtec-driver_version3.zip
2016-12-05 10:55 toncho11 Note Added: 0001227
2016-12-05 10:56 jtlindgr Assigned To => jtlindgr
2016-12-05 10:56 jtlindgr Status new => acknowledged
2016-12-07 12:51 jtlindgr Note Added: 0001231
2016-12-07 12:51 jtlindgr Status acknowledged => resolved
2016-12-07 12:51 jtlindgr Resolution open => fixed
2016-12-07 18:18 toncho11 Note Added: 0001232
2016-12-07 18:18 toncho11 Status resolved => feedback
2016-12-07 18:18 toncho11 Resolution fixed => reopened
2016-12-08 11:04 toncho11 Note Added: 0001233
2016-12-08 11:04 toncho11 Status feedback => assigned
2016-12-08 11:23 jtlindgr Note Added: 0001234
2016-12-08 13:37 toncho11 Note Added: 0001235
2016-12-08 13:38 toncho11 Note Edited: 0001235 View Revisions
2016-12-08 14:26 jtlindgr Note Added: 0001236
2016-12-08 14:26 jtlindgr Status assigned => resolved
2016-12-08 14:26 jtlindgr Resolution reopened => fixed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker