Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000170openvibe-designerbug reportpublic2015-02-25 10:572015-09-10 14:26
Reportertoncho11 
Assigned Tojtlindgr 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionunable to reproduce 
PlatformOpenVibe 0.18OSWindows 7OS Version
Summary0000170: Zlib1.dll dependency?
DescriptionI made a fresh install of OpenVibe 0.18 and I could not start it.
It requested zlib1.dll.
Additional InformationI downloaded the zlib from sourceforge and it worked.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001192)
jtlindgr (administrator)
2015-02-25 12:57

Unfortunately, can't reproduce. The dll file is installed to

openvibe/dependencies/gtk/bin/zlib1.dll

and the launcher scripts should set the path there using bin/openvibe-set-env.cmd. I can only assume that something specific to your system interferes with the install mechanism so that either the zlib1.dll file is not there, or the set-env command does not set the path. Which one is it, or neither?

(0001201)
jtlindgr (administrator)
2015-09-10 14:26

Closing as unable to reproduce. One possible cause for problems like this can be if there is e.g. another version of gtk in %PATH% before the openvibe version, requesting zlib1 from a place where it is not. One way to test this possibility is to add

SET PATH=

at the beginning of the .cmd launch script. Also, dependency walker may be useful to see what exactly is requesting a library.

- Issue History
Date Modified Username Field Change
2015-02-25 10:57 toncho11 New Issue
2015-02-25 12:57 jtlindgr Note Added: 0001192
2015-02-25 12:57 jtlindgr Assigned To => jtlindgr
2015-02-25 12:57 jtlindgr Status new => feedback
2015-09-10 14:26 jtlindgr Note Added: 0001201
2015-09-10 14:26 jtlindgr Status feedback => resolved
2015-09-10 14:26 jtlindgr Resolution open => unable to reproduce


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker