OpenViBE Bug Tracker - openvibe-designer
View Issue Details
0000170openvibe-designerbug reportpublic2015-02-25 10:572015-09-10 14:26
toncho11 
jtlindgr 
normalminorhave not tried
resolvedunable to reproduce 
OpenVibe 0.18Windows 7
0000170: Zlib1.dll dependency?
I made a fresh install of OpenVibe 0.18 and I could not start it.
It requested zlib1.dll.
I downloaded the zlib from sourceforge and it worked.
No tags attached.
Issue History
2015-02-25 10:57toncho11New Issue
2015-02-25 12:57jtlindgrNote Added: 0001192
2015-02-25 12:57jtlindgrAssigned To => jtlindgr
2015-02-25 12:57jtlindgrStatusnew => feedback
2015-09-10 14:26jtlindgrNote Added: 0001201
2015-09-10 14:26jtlindgrStatusfeedback => resolved
2015-09-10 14:26jtlindgrResolutionopen => unable to reproduce

Notes
(0001192)
jtlindgr   
2015-02-25 12:57   
Unfortunately, can't reproduce. The dll file is installed to

openvibe/dependencies/gtk/bin/zlib1.dll

and the launcher scripts should set the path there using bin/openvibe-set-env.cmd. I can only assume that something specific to your system interferes with the install mechanism so that either the zlib1.dll file is not there, or the set-env command does not set the path. Which one is it, or neither?

(0001201)
jtlindgr   
2015-09-10 14:26   
Closing as unable to reproduce. One possible cause for problems like this can be if there is e.g. another version of gtk in %PATH% before the openvibe version, requesting zlib1 from a place where it is not. One way to test this possibility is to add

SET PATH=

at the beginning of the .cmd launch script. Also, dependency walker may be useful to see what exactly is requesting a library.