OpenViBE forum

The OpenViBE community
It is currently Wed Dec 12, 2018 2:21 pm

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Motor-imagery-CSP
PostPosted: Wed May 09, 2018 3:44 pm 
Offline

Joined: Thu Mar 29, 2018 6:28 am
Posts: 13
Location: Bask Country
Hi guys
I intend this scenario ( to work with Unity after).
But i'm in the 5th scenario and it works like this?

-> You know what is putting "please retrain your classifier using your current openVibe version?"
-> Boost ASIO connection error ?

Image


thank you !


Top
 Profile  
Reply with quote  
 Post subject: Re: Motor-imagery-CSP
PostPosted: Thu May 10, 2018 9:06 am 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 772
Location: INRIA Rennes, FRANCE
Hello,

the classifier processor box is trying to load some old file instead of file generated by a previous step. Check file paths in the trainer and processor boxes and make sure you've run all steps. The asio error could be due to acquisition server not being in the play state while you run the scenario.

Best,
Jussi


Top
 Profile  
Reply with quote  
 Post subject: Re: Motor-imagery-CSP
PostPosted: Thu May 10, 2018 3:51 pm 
Offline

Joined: Thu Mar 29, 2018 6:28 am
Posts: 13
Location: Bask Country
Great

Thank you. So the file paths must be the same in " Stream writer" and " processor boxes".
In the last one, I put on a special file "processor"


To understand better, The direction ( on the picture) must to be show the the file path of my last
file ? or motor-imagery-bci-config-classifier.cfg?
thanks




jtlindgren wrote:
Hello,

the classifier processor box is trying to load some old file instead of file generated by a previous step. Check file paths in the trainer and processor boxes and make sure you've run all steps. The asio error could be due to acquisition server not being in the play state while you run the scenario.

Best,
Jussi


Attachments:
processor(1).JPG
processor(1).JPG [ 165.91 KiB | Viewed 744 times ]
Top
 Profile  
Reply with quote  
 Post subject: Re: Motor-imagery-CSP
PostPosted: Thu May 10, 2018 5:41 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 772
Location: INRIA Rennes, FRANCE
It must point to a classifier file created by Classifier Trainer box successfully run beforehand, typically in another training scenario.


Cheers,
Jussi


Top
 Profile  
Reply with quote  
 Post subject: Re: Motor-imagery-CSP
PostPosted: Thu May 10, 2018 5:45 pm 
Offline

Joined: Thu Mar 29, 2018 6:28 am
Posts: 13
Location: Bask Country
jtlindgren wrote:
It must point to a classifier file created by Classifier Trainer box successfully run beforehand, typically in another training scenario.


Cheers,
Jussi


Hi So i point the file to the classifier Trainer. and point the configuration to the classifier processor.
I restart since the beguinning and the problem rests.

I put here the scenario of the "config-classifier"
Code:
<OpenViBE-Classifier-Box XMLVersion="3">
   <Strategy-Identifier class-id="(0xffffffff, 0xffffffff)">Native</Strategy-Identifier>
   <Algorithm-Identifier class-id="(0x2ba17a3c, 0x1bd46d84)">Linear Discrimimant Analysis (LDA)</Algorithm-Identifier>
   <Stimulations>
      <Class-Stimulation class-id="1">OVTK_GDF_Left</Class-Stimulation>
      <Class-Stimulation class-id="2">OVTK_GDF_Right</Class-Stimulation>
   </Stimulations>
   <OpenViBE-Classifier>
      <LDA>
         <Classes>1 2</Classes>
         <Weights> -1.390939e+01 -3.837006e+01 -3.951661e+00 1.267055e+02 8.129262e+00 1.130540e+02</Weights>
         <Bias-distance>1.04657</Bias-distance>
         <Coefficient-probability>1.15779</Coefficient-probability>
      </LDA>
   </OpenViBE-Classifier>
</OpenViBE-Classifier-Box>

thanks


Top
 Profile  
Reply with quote  
 Post subject: Re: Motor-imagery-CSP
PostPosted: Sat May 12, 2018 6:44 pm 
Offline

Joined: Thu Mar 29, 2018 6:28 am
Posts: 13
Location: Bask Country
You can close the discussion.

It works!!!!


for others:

-> check your driver.
-> check your files pathes
-> keep during the session until the final!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.