Build Error on Win7 x64 and VS2010

Post Reply
Posts: 1
Joined: Tue Aug 04, 2015 1:01 pm

Build Error on Win7 x64 and VS2010

Post by FabainHH »


i need to compile OpenVibe with a new Driver. If i install the software by executable it works fine but i got my own hardware and so i need my own driver.
My System
- Windows 7 Professional 64 Bit
- MS Visual Studio c++ 2010 Expres
- MS Windows SDK 7.1
- MS Visual c++ 2010 x86 Redistributable 10.0.40219
- MS Visual c++ Compilers 2010 SP1 x86
( and some other Redistributable for x86/64 and 2005/2008/2010)

I am able to install all dependecies and i have tried reinstalling and building multiple times. I have even tried reinstalling MS Studios and SDK (SDK did some troubles).
But i recieve the same error while building the hole time:

in the "CMakeOutput.log" is no Error and nothing failed. I tried to figure out the error in CMakeDetermineVSSerivePack but i cant fix it.

Seems like there is somethin wrong with my Visual c++ ? Maybe it comes from the Windows SDK? Can maybe someone tell me which versions i realy need?!

I spend a hoel day and tried to fix this but i was not able to... this is my PC at work. At home i have Win 8.1 64 bit (what is not supported) but i only installed Visual Studios 2010 Express and i was able to Build and run the Project without any issues. It would be a lot more work for me if i need to write and debug the driver at home, so i would prefer to be able to build it on my work Computer =)

Posts: 775
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Build Error on Win7 x64 and VS2010

Post by jtlindgren »

Hi Fabain,

problems with VS/CMake combo are sometimes tricky to trace as the error output is not very informative.

As a first idea, have you installed the latest service pack to your VS2010 (or is it the same as your C++ compiler SP)?

I also notice you're trying to build with the command line build script. What if you use the IDE build? (scripts win32-generate-vc-proj followed by

Sometimes people have had trouble if they've uninstalled some VS versions before, possibly leaving the compiler info (in registry or such) in an inconsistent state. Perhaps you could try checking if you can build some other cmake based software on your VS2010 setup?


Post Reply