Failed to find Emotiv API

Making & changing hardware drivers in Acquisition Server
Post Reply
Posts: 42
Joined: Fri Jul 08, 2011 9:32 am

Failed to find Emotiv API

Post by chantrip »

Dear Openvibe team

I have Epoc driver installed at 'C:\Program Files\Emotiv Research Edition SDK_v1.0.0.5-PREMIUM' and have tried to install Openvibe13. My OS is Windows 7. However, when I run win32-build, the log message attached here shows 'Failed to find Emotiv API' and I cannot use EPOC with Openvibe. Could you please tell me how to fix this problem?

Thank you very much

Log.png (254.81 KiB) Viewed 5067 times

Posts: 239
Joined: Tue Nov 02, 2010 8:51 am
Location: Mensia Technologies Paris FR

Re: Failed to find Emotiv API

Post by jlegeny »

Hello Jim,

the path to the version of the Emotiv SDK is indeed missing in the Cmake file. In order to fix your problem edit the cmake-modules/FindThirdPartyEmotivAPI.cmake file and insert this two following lines to the FIND_PATH statement

"C:\Program Files\Emotiv Research Edition SDK_v1.0.0.5-PREMIUM"
"C:\Program Files\Emotiv Research Edition SDK_v1.0.0.5-PREMIUM/doc/examples/include"

We will include this fix in the svn. Thank you for the heads up.


Posts: 1
Joined: Wed May 11, 2016 12:31 pm

Re: Failed to find Emotiv API

Post by Yourka »


i've a similar problem,

i'm running on Ubuntu 14.04, the openvibe compilatino works except the "FAILED to find Emotiv API".

the problem is that Emotiv is not using (see #) anymore.

Code: Select all

        "C:/Program Files/Emotiv Development Kit*"
        "C:/Program Files/Emotiv Research Edition*"
i've asked Emotiv what to use instead, they linked me that file : which has nothing about how to use it.

can you help me on finding the path to find the Emotiv API ?

thank you,

Guillaume Doncieux

Post Reply