OpenBCI with Acquisition server

Obtaining data from various hardware devices
Post Reply
soultranscender
Posts: 4
Joined: Mon Jan 18, 2016 12:42 pm

OpenBCI with Acquisition server

Post by soultranscender »

We recently bought the newest OpenBCI Cyton board and its kit. After following the tutorial from

http://openvibe.inria.fr/drivers-openbci/

and

http://docs.openbci.com/3rd%20Party%20S ... 3-OpenViBE

and after installing the necessary FTDI drivers, we tried to connect acquisition server(OpenViBE v1.3 built from source). Unfortunately we did not succeed in doing so neither on Windows 10, 7 nor on Ubuntu 14.04 LTS. The OpenViBE's acquisition server could connect to the port, but could not identify the hardware. Attached is the screenshot of acquisition server log. Can you please suggest if there is something that we are missing or is it that OpenViBE has stable drivers for Ganglion board and not for Cyton board. Well one more thing what we noticed was, with older version of OpenViBE (1.1, 1.2, 1.2.2) the hardware connected but as soon as we play the streaming of data it closed the connection. we will try some more things and update this post. Meanwhile any suggestions can be helpful.

Best Regards
Attachments
Acquisition server log where it could not detect OpenBCI device
Acquisition server log where it could not detect OpenBCI device
Capture.JPG (111.74 KiB) Viewed 4554 times

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: OpenBCI with Acquisition server

Post by jtlindgren »

Hi,

the driver is a community contribution, so the best chance might be to try to catch the contributors (see http://openvibe.inria.fr/supported-hardware/ page)! And the OpenBCI people should know what are the differences between the two devices.

Meanwhile, to get some more debug information about the thing, modify openvibe.conf and set

Code: Select all

Kernel_MainLogLevel = Trace
This should give you more printouts from the OpenBCI driver. At a glance it looks like the code parses the device version information to be zero and uses that to decide that its an unknown device. Either that, or it doesn't even go to the parsing part. We don't have OpenBCI equipment at Inria Rennes afaik so from my side its difficult to speculate further. :s


Happy hacking,
Jussi

soultranscender
Posts: 4
Joined: Mon Jan 18, 2016 12:42 pm

Re: OpenBCI with Acquisition server

Post by soultranscender »

Thank you, Jussi for the information on debugging it helped.

Update: In driver properties just set Board Reply Reading Timeout and Board Reply Flushing Timeout to 30000 ms, and it should solve the above issue. Anyway we did not investigate in depth to find the appropriate values. May be you can try changing the values to what is best suitable to your needs.

There are issues where the connection does not work every time we try to connect, thus considering it to be unstable we will further investigate it to see how we can solve it.

Best Regards,
Guruprasad

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: OpenBCI with Acquisition server

Post by jtlindgren »

Thats good to know, thank you. Hopefully it'll help other people who have also had problems with the timeout and the Cyton board.


Cheers,
Jussi

a1eks
Posts: 6
Joined: Sun Jan 21, 2018 6:26 pm

Re: OpenBCI with Acquisition server

Post by a1eks »

Hi all,

I have a question. Does Acquisition Server works with OpenBci wifi shield https://shop.openbci.com/products/wifi- ... 4534009550 ?

Post Reply