OpenViBE forum

The OpenViBE community
It is currently Mon Jan 22, 2018 8:04 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Tue Aug 16, 2016 11:47 am 
Offline

Joined: Thu Aug 11, 2016 12:08 pm
Posts: 1
Hi,

We're currently working on a set-up to collect data with a (slightly
modified) Emotiv EEG headset (version 1.0; note that we're still using the provided
amplifier).
For stimulus presentation we chose the "Presentation (Neurobs)" software (17.1)
and to collect the data we use OpenVibe (1.1.0).
Anyway, the presentation of stimuli and the recording of EEG data works
perfectly fine but it seems impossible to create a dataset that brings
both together - the triggers sent by presentation and the EEG recording.
We tried to use Labrecorder (1.11) and the LSL (which should do the job) in the
following set-up:
PC A was used to collect the EEG data using OpenVibe and also to run
Labrecorder during the experiment. PC B simply presented the stimuli
(via Presentation).
The resulting record (we use Matlab/EEGlab for the evaluation) actually
combines both signals but with different timestamps: the triggers sent
by PC B get marked with the uptime (NOT the system time) by PC A. This
is most probably done by Labrecorder.
Is/Was anyone struggling with a comparable problem/set-up?
Our aim is obviously to fix the timestamp issue. I'd be glad about any kind of help although I'm not in the position to change major parts of the setup.
If anyone worked with a similar setup using PsychoPy instead of Presentation, please contact me! I'm really curious.

Regards,
Marta


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 18, 2018 11:18 pm 
Offline

Joined: Thu Jan 18, 2018 4:15 pm
Posts: 4
Hello, I am actually facing the same issue with Presentation and OpenVibe (sending triggers from Presentation to OpenVibe), did you find a solution to the problem? Thank you!


Top
 Profile  
Reply with quote  
PostPosted: Fri Jan 19, 2018 12:02 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 618
Location: INRIA Rennes, FRANCE
Hi Jessica,

if Presentation allows you to write plugins in it in some programming language, maybe you could use the plugin to send information towards openvibe. In case of markers/stimulations, what we call 'TCP Tagging' would probably be the way to go.

You can find a description of different ways openvibe can communicate with other programs here,

http://openvibe.inria.fr/overview-sendi ... -openvibe/


Best,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Sat Jan 20, 2018 9:27 pm 
Offline

Joined: Thu Jan 18, 2018 4:15 pm
Posts: 4
Jussi,

I've read through the documentation multiple times and attempted TCP tagging from the Presentation side but without success.
When I use the tagging port 15361, and an active acquisition server, I do see signal entering Presentation but don't quite understand how to add a marker to the stream.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.