Support for Emotiv's EPOC+

Obtaining data from various hardware devices
soultranscender
Posts: 4
Joined: Mon Jan 18, 2016 12:42 pm

Support for Emotiv's EPOC+

Post by soultranscender »

Hello,
Has anyone tried to make Emotiv's EPOC+ work with acquisition server ? As there are no edk.dll or edkutils.dll file available anymore in the Emotiv control panel which comes with EPOC+ headset. The old Emotiv EEG headset workings with OpenVibe but the new EPOC+ does not. Has the support for new EPOC+ headset been added. If so please share.

The solution in the following link does not work for the EPOC+ headset as of we have tried.

http://openvibe.inria.fr/how-to-connect ... -openvibe/

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Support for Emotiv's EPOC+

Post by jtlindgren »

+1 to this, if anybody is willing to contribute code compatible with newer Emotiv SDKs or devices, we'd be happy to include that in OpenViBE. Presently the ov core team has no plans to implement such support. We are unfortunately very busy and have no access to the newer devices/SDKs.


Best,
Jussi

YenBen
Posts: 5
Joined: Mon Oct 24, 2016 5:13 pm

Re: Support for Emotiv's EPOC+

Post by YenBen »

Recently I bought EPOC+ as well. But there is a edk.dll found in emotiv folder, the path is showed as :

C:\Program Files (x86)\Emotiv SDK Premium Edition v3.3.2\EDK\x86.

However I cannot connect with OpenVibe, it always shows me error message.

Do we need to change the openvibe's soucecode by ourselves? which file do I need to modify? kindly advice please.

Thank you

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Support for Emotiv's EPOC+

Post by jtlindgren »

Hello YenBen,

if you know programming and have the SDK, it'd definitely be possible to modify the existing driver to work with the newer SDKs. This would pretty much mean looking at the old OpenViBE C++ Emotiv driver code and/or CMake scripts of OpenViBE and make changes as dictated by the changes in the Emotiv SDK since 1.0.0.4. That is, find out where problem(s) come from and then address them, possibly using Emotivs developer documentation and examples as a guidelines. However, this takes some basic software engineer skill and time.


My 3 cents,
Jussi

YenBen
Posts: 5
Joined: Mon Oct 24, 2016 5:13 pm

Re: Support for Emotiv's EPOC+

Post by YenBen »

Thank you Jussi, I will try on it. :)

LeeFX
Posts: 24
Joined: Wed Dec 17, 2014 2:52 pm

Re: Support for Emotiv's EPOC+

Post by LeeFX »

Okay this is super weird, NONE of the versions (3.3.3, 2.0.0.20, 1.0.0.5, 1.0.0.4) worked earlier today, then I thought I had missed something, because 1.0.0.5 was suddenly working some hours later, but then I tried the other versions again and these suddenly worked too... (only 1.0.0.4 leads to a crash when starting the acquisition!)

Win7 64
OpenVibe 1.2.2

YenBen
Posts: 5
Joined: Mon Oct 24, 2016 5:13 pm

Re: Support for Emotiv's EPOC+

Post by YenBen »

Dear LeeFx,

How did you change the setting? did u run it with source code ? can you share your setting with me?

Currently I am using windows 8.

thank you.

LeeFX
Posts: 24
Joined: Wed Dec 17, 2014 2:52 pm

Re: Support for Emotiv's EPOC+

Post by LeeFX »

This could be a workaround

Version 1: Start Acquisition Server - Select 3.3.3 EDK folder -> fails to connect
Version 2: Start Acquisition Server - Select 1.0.0.5 folder - connect - disconnect - Select 3.3.3 EDK Folder -> successfully connects

Can you confirm this @YenBen?

It seems to me, that 1.0.0.5 is the most stable, but it didn't quite connect all the time.
1.0.0.4 seems to connect as often as 1.0.0.5, but constantly leads to a crash when starting the acquisition

What I also noticed, the folder structures are different from 3.3.3 and 1.0.0.5! 3.3.3 has multiple edk.dll and edk.lib, separated in x32 and x64 folders.
Maybe this could lead to a wrong reference in some situations?

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Support for Emotiv's EPOC+

Post by jtlindgren »

Hello Lee & Yenben,

Openvibe Acquisition Server is compiled 32bit, so you need to make sure it always loads the 32 bit .dll. You can use Process Monitor to verify that its not taking the wrong files. Sometimes there can be problems if several versions of some dependency or library are installed at the same time on the same computer.

Its good to know if 1.0.0.5 works better. Though not sure what should be recommended if it has connection problems. The OV driver was originally developed with 1.0.0.4 I think, but its a long time.


Best,
Jussi

YenBen
Posts: 5
Joined: Mon Oct 24, 2016 5:13 pm

Re: Support for Emotiv's EPOC+

Post by YenBen »

Dear LeeFx,

sadly to say that I just have latest version, so I couldn't test the ver 1.0.0.5. :(

Currently I am planning to apply p300 to authentication field. Is it possible if we never send any marker while recording the eeg data? :lol:

LeeFX
Posts: 24
Joined: Wed Dec 17, 2014 2:52 pm

Re: Support for Emotiv's EPOC+

Post by LeeFX »

@jtlindgren

no I mean, 1.0.0.5 was by far the most stable and 1.0.0.4 always crashes ;)
the thing is, loading 3.3.3 directly never works. even selecting the x86 Folder directly, does not work!

Preloading 1.0.0.5 EDKs and then selecting the folder of 3.3.3 (even without selecting 32/64 subfolders) seems to make it connect properly. As if some interaction / recursion is going on between EDK reloading states... and loading 1.0.0.5 overrides the connection error of 3.3.3 :?

caitlinvz
Posts: 4
Joined: Wed Nov 02, 2016 11:20 pm

Re: Support for Emotiv's EPOC+

Post by caitlinvz »

Hi everyone,

I have an EMOTIV Insight and I want to try and do some experiments for a thought controlled keyboard.

A couple of questions:
- where did you get the SDK from. I filled in an application on the EMOTIV site and they sent me a link to the community SDK?
- does the edk.dll also come with the EMOTIVE XAVIER PURE.EEG software?

Thanks

soultranscender
Posts: 4
Joined: Mon Jan 18, 2016 12:42 pm

Re: Support for Emotiv's EPOC+

Post by soultranscender »

Hello,

The EPOC+ works with OpenVibe, I have tested it with Emotiv Research Edition SDK v2.0.0.20 but the data obtained does not look like a valid EEG data, the whole data has amplitudes between 2000 to -2000 for all the channels. Do yo know what this data might be and what might be causing such high amplitudes. BTW we are in process of obtaining access to Emotiv SDK v3.3.3 from Emotiv, can you also suggest if we will need access to pure.EEG or it is advanced SDK what we should try to obtaining access to ?
Last edited by soultranscender on Tue Jan 03, 2017 11:09 pm, edited 1 time in total.

LeeFX
Posts: 24
Joined: Wed Dec 17, 2014 2:52 pm

Re: Support for Emotiv's EPOC+

Post by LeeFX »

thanks to jtlindgren, the next release of openvibe will feature a newer version of the acquisition server to be compatible with the newer SDK versions, (3.3.3 +)

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Support for Emotiv's EPOC+

Post by jtlindgren »

OpenViBE 1.3.0 is now out and should work with the 3.3.3 SDK. However, the older SDKs do not work with the same Acquisition Server binary. If needed, see notes at http://openvibe.inria.fr/supported-hardware/


Cheers,
Jussi

Post Reply