Failed to create VRPN analog server

Obtaining data from various hardware devices
Post Reply
shin
Posts: 2
Joined: Thu Oct 31, 2013 7:33 am

Failed to create VRPN analog server

Post by shin »

Hi everybody,

I've got a little problem with running acquisition server.This message is displayed When I try to run the scenario.

[ ERROR ] At time 0.031 sec <Box algorithm::Analog VRPN Server> Failed to create VRPN analog server for 448 channel(s)
[WARNING] Box algorithm <Analog VRPN Server> has been deactivated because process phase returned bad status

I don't know why such a message is displayed.By the way, I am using emotive EPOC and I am connected scenarios Acquisition client and Analog VRPN Server.

I apologize if I am asking too basic questions,but I don't know what to do.

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Failed to create VRPN analog server

Post by jtlindgren »

Hello Shin,

what are you trying to do? The problem likely is that the channel count you mention is way too high for Analog VRPN Server. What happens is that Acquisition Server sends out the signal in blocks (matrices), where each matrix has size [numChannels, numSamplesPerBlock]. Analog VRPN server interprets each matrix slot as its own channel. So, for example 16 channels and 32 samples per block, you get 512 Analog VRPN channels, already too high (128 seems to be the max).

In general the VRPN server is more suitable for sending out some small-scale, processed signal than large amounts of raw data.


Cheers,
Jussi

yrenard
Site Admin
Posts: 645
Joined: Fri Sep 01, 2006 3:39 pm
Contact:

Re: Failed to create VRPN analog server

Post by yrenard »

There is indeed a hard-coded maximum size for VRPN servers, this limitation comes from VRPN and has been preserved for better compatibility with other VRPN based applications. If this is too annoying, you can change this in VRPN source code and recompile it along to OpenViBE.

Hope this helps,
Yann

shin
Posts: 2
Joined: Thu Oct 31, 2013 7:33 am

Re: Failed to create VRPN analog server

Post by shin »

Thanks for the reply,

I've found the cause of the error thanks to the two of you.I was able to know about the specifications of the of Open Vibe.The next, I try to challenge another approach.

Post Reply