Missing drivers for Linux (gtec gUSBamp, getec gNautilus Set, Unicorn Set)

Obtaining data from various hardware devices
Post Reply
thunfisch96
Posts: 7
Joined: Wed May 12, 2021 2:27 pm

Missing drivers for Linux (gtec gUSBamp, getec gNautilus Set, Unicorn Set)

Post by thunfisch96 »

Hello,
I own the following hardware components:
- getec gUSBamp
- getec gNautilus Set
- Unicorn Set

We would like to develop an all in one system on a Raspberry Pi 4. We are working on the Linux version: Ubuntu 18.04 and Openvibe 3.1.0.
The last update of Acquisition devices and drivers in OpenViBE is from 2018, are there already updates for drivers on 64-bit?

Cheers
Thunfisch

Thomas
Posts: 68
Joined: Wed Mar 04, 2020 3:38 pm

Re: Missing drivers for Linux (gtec gUSBamp, getec gNautilus Set, Unicorn Set)

Post by Thomas »

Hi Thunfisch,

It's been a while since hardware drivers were added for linux indeed, and the only driver you can use at the moment is the gUSBamp.

There is no need to update the OpenViBE driver to build for 64bit architecture.
When compiling OpenViBE with the 64bit hardware API installed in /usr/lib or /usr/local/lib the build process will pick it up and compile the driver which will then appear in the acquisition server drivers list.

Hope this helps, let us know how you get on with the build on the Raspberry!

Cheers,
Thomas

Post Reply