Problems starting the acquisition from 2 acquisition servers

Obtaining data from various hardware devices
Post Reply
kyunghowon
Posts: 10
Joined: Tue Jan 03, 2017 7:12 am

Problems starting the acquisition from 2 acquisition servers

Post by kyunghowon »

Hi all,

I'm trying to test BCI application using OpenViBE and Unity3D, and use LSL acquisition server for sending/receiving signals between them.

My pipelines are below:

step1. launch Unity3D application that has a code for LSL marker and signal stream (named my_signal, my_marker)
step2. launch acquisition server - LSL (in config, select my_signal and my_marker) -> connect, play
step3. launch acquisition server - DSI-24 -> connect, play
step4. launch designer and play my scenario
It works on v2.1.0, OpenViBE -32bit

After v2.2.0, OpenViBE does not allow me to play multiple acquisition server with the error, "Could not create tag stream for TCP Tagging [bind:"

Any suggestions? or could you correct my mistakes?

Thank you,
Kyungho Won

Thibaut
Posts: 225
Joined: Wed Oct 31, 2018 9:14 am

Re: Problems starting the acquisition from 2 acquisition servers

Post by Thibaut »

HI,
I have never try to launch 2 acquisition server.
The best way for me is to use the box lsl export (or import) and acquisition only for acquisition of your driver.
Thibaut

kyunghowon
Posts: 10
Joined: Tue Jan 03, 2017 7:12 am

Re: Problems starting the acquisition from 2 acquisition servers

Post by kyunghowon »

Dear Thibaut.

Sorry for late response and I appreciate your help :)

I found that the problem was TCP tagging port.

In my experience, OV above 2.2.0 does not allow me to use the same TCP tagging port even though I did not enable TCP tagging.

My problem was solved after I changed TCP tagging port for each acquisition server.

Your suggestion, using LSL export box, is great and I'm already using it, but that box only exports data to the external application, and cannot import markers.

I don't know whether OV intended using multiple acquisition servers, but somehow I tried connecting two EEG devices simultaneously and it worked, showing not the best, but not bad delays.

Thank you!
Kyungho Won

Thibaut
Posts: 225
Joined: Wed Oct 31, 2018 9:14 am

Re: Problems starting the acquisition from 2 acquisition servers

Post by Thibaut »

yes the port must be different of course.

Post Reply