OpenViBE forum

The OpenViBE community
It is currently Sun Sep 24, 2017 6:49 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Apr 06, 2017 1:46 pm 
Offline

Joined: Wed Apr 05, 2017 10:48 am
Posts: 3
Hello!!!!

I want to use the P300 speller with Enobio 8 (neuroelectrics).
I'm using openViBE 1.3.0 on Linux and, apparently, the device is not supported. However, the manual says that it's compatible, is it the case? How can I include it, or which device should I select within the acquisition server in order to visualize the signals? Thank you very much in advance!!

Best,
Cecilia


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 07, 2017 8:20 am 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 564
Location: INRIA Rennes, FRANCE
Hi Cecilia,

I don't know if the Enobio3G driver supports the '8' version of the device. This'd be better verified from the company that contributed the driver.

If it should work, read on. :)

First, it seems that the Linux code is there in principle, but I don't know how well it has been tested or if it works. Again, try checking from the contributor (the Neuroelectrics company). From what I can see, you could try to get it to work as follows,

1) Get the Enobio linux libraries compatible with your Linux distribution and cpu architecture (64bit need 64bit libs etc) from the Neuroelectrics company
2) Remove the disabling of the driver from openvibe in cmake-modules/FindThirdPartyNeuroElectricsEnobio3G.cmake
3) Extract the Enobio library archive so that the script above can find it; make sure symbolic links point correctly
4) You may need to install qt4-default pkg
5) Rebuild openvibe
6) If it doesn't find some lib when you launch the server, copy the enobio libs to dist/lib/


Cheers,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Tue Apr 11, 2017 4:26 pm 
Offline

Joined: Wed Apr 05, 2017 10:48 am
Posts: 3
Thank you very much Jussi!!!! Will try it :)


Top
 Profile  
Reply with quote  
PostPosted: Wed Jul 12, 2017 10:30 am 
Offline

Joined: Wed Apr 05, 2017 10:48 am
Posts: 3
Hello Jussi!!!

I've seen that the acquisition server includes now ENOBIO3G :)
However, I don't manage to connect the device...it seems to me that when I enter the MAC address through the driver properties and click "apply" it gets removed. Do you have any suggestion?
Thanks a lot!!!!


Best,
Cecilia


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.