OpenViBE forum

The OpenViBE community
It is currently Wed Apr 24, 2019 6:12 pm

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Mar 24, 2018 11:09 am 
Offline

Joined: Tue Mar 13, 2018 12:39 pm
Posts: 12
Hi!

I have compiled OV on Debian 9.3 and am able to run the application, however, some of the boxes are missing (not available). For example; acquisition client, sinus oscillator, confusion matrix, MI-related boxes, etc. I guess something went wrong (missing dependency) during the compilation. Can you point me what is likely to be wrong?

Thanks!
Filip


Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 27, 2018 7:53 am 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 778
Location: INRIA Rennes, FRANCE
Hi,

Debian is not an officially supported platform -- usually Debians work with small tweaks or by adding hand-installed stuff. Likely some packages in it can be too old (e.g. boost).

You can look which components cmake is not able to find with the required version (at the beginning of the build), it should mention them. Perhaps the easiest is to copy paste the list here so I can throw an educated guess.


Best,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 04, 2018 7:14 am 
Offline

Joined: Tue Mar 13, 2018 12:39 pm
Posts: 12
Hi again,

I tried looking into the build log, but the missing dependencies seem to be non-essential to the missing boxes:
Code:
$ grep -i fail rebuild.log
--   FAILED to find liblsl (optional) ...
--   FAILED to find VRPN
--   FAILED to find Emotiv API (optional driver)
--   FAILED to find MindMedia NeXus device dll (optional driver)
--   FAILED to find MCS device SDK (optional driver)
--   FAILED to find Mensia Acquisition driver (optional driver)
--   FAILED to find Micromed device dlls (optional driver)
--   FAILED to find TMSi device dll (optional driver)
--   FAILED to find EEGO API (optional driver) - cmake looked in '/home/xskola/dev/openvibe-2.0.1-src/dependencies/home/xskola/dev/openvibe-2.0.1-src/extras/dependencies', skipping EEGO.
--   FAILED to find GMobiLabPlusAPI... (optional driver)
--   FAILED to find GUSBAmpAPI Linux... (optional)
--   FAILED to find Mitsar device dll (optional driver)


The full log file is here: https://www.fi.muni.cz/~xskola/rebuild.log. If you see anything suspicious there, please throw your ideas! Thanks a lot!

Filip


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 04, 2018 10:34 am 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 778
Location: INRIA Rennes, FRANCE
Hi,

that is quite odd, nothing in your log explains it. A colleague was suggesting that maybe its loading the libs from another location due to some previous build or something? When you launch Designer, what does it print? Can you copy paste here? Also, it'd be useful to have a full log of a clean build (delete build/ and dist/ and run build.sh again while redirecting to a file, i.e. build.sh >dump.txt).


Cheers,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 04, 2018 12:55 pm 
Offline

Joined: Tue Mar 13, 2018 12:39 pm
Posts: 12
The library location should be clear (empty LD_LIBRARY_PATH), previous builds are not installed on the computer. I tried the clean build, the log is here: https://www.fi.muni.cz/~xskola/build.log.

The following is the output from running openvibe-designer.sh:
Code:
2345 (process ID) old priority 0, new priority 19
[  INF  ] Created kernel loader, trying to load kernel module
[  INF  ] Kernel module loaded, trying to get kernel descriptor
[  INF  ] Got kernel descriptor, trying to create kernel
[  INF  ] Adding kernel configuration file [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/kernel/openvibe.conf]
[  INF  ] Logging to '/home/xskola/.config/openvibe-2.0/log/openvibe-designer.log'
[  INF  ] Syntax :
[  INF  ] Adding plugins from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-*.so]
[  INF  ] Added 17 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-advanced-visualization.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-examples.so]
[  INF  ] Added 3 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-simple-visualization.so]
[  INF  ] Added 10 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-classification.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-data-generation.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-feature-extraction.so]
[  INF  ] Added 9 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-file-io.so]
[  INF  ] Added 24 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-signal-processing.so]
[  INF  ] Added 5 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-stimulation.so]
[  INF  ] Added 19 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-stream-codecs.so]
[  INF  ] Added 2 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-streaming.so]
[  INF  ] Added 3 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-tools.so]
[  INF  ] Adding metaboxes from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/metaboxes/;/home/xskola/.config/openvibe-2.0/metaboxes/]
[  INF  ] Added 0 metaboxes from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/metaboxes/]
[  INF  ] Added 0 metaboxes from [/home/xskola/.config/openvibe-2.0/metaboxes/]
[  INF  ] Initialization took 134 ms
[  INF  ] Application terminated, releasing allocated objects


Plus also attaching the detailed log from $home/.config in case this is helpful.


Attachments:
openvibe-designer.log [18.58 KiB]
Downloaded 53 times
Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 04, 2018 1:07 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 778
Location: INRIA Rennes, FRANCE
Ah, now its becoming more clear! The reason is probably that you run Designer from its own sub-distribution. To get all the modules that correspond to the full openvibe distribution, you need to launch it from 'dist/extras-Release/'. Can you try that and let me know if it works?

Cheers,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 04, 2018 1:15 pm 
Offline

Joined: Tue Mar 13, 2018 12:39 pm
Posts: 12
Oh my, such a stupid mistake! Thanks a ton, I run the script from extras-Release and everything seems to work like a charm now.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.