Missing boxes after compiling on Linux

Post Reply
xskola
Posts: 12
Joined: Tue Mar 13, 2018 12:39 pm

Missing boxes after compiling on Linux

Post by xskola »

Hi!

I have compiled OV on Debian 9.3 and am able to run the application, however, some of the boxes are missing (not available). For example; acquisition client, sinus oscillator, confusion matrix, MI-related boxes, etc. I guess something went wrong (missing dependency) during the compilation. Can you point me what is likely to be wrong?

Thanks!
Filip

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Missing boxes after compiling on Linux

Post by jtlindgren »

Hi,

Debian is not an officially supported platform -- usually Debians work with small tweaks or by adding hand-installed stuff. Likely some packages in it can be too old (e.g. boost).

You can look which components cmake is not able to find with the required version (at the beginning of the build), it should mention them. Perhaps the easiest is to copy paste the list here so I can throw an educated guess.


Best,
Jussi

xskola
Posts: 12
Joined: Tue Mar 13, 2018 12:39 pm

Re: Missing boxes after compiling on Linux

Post by xskola »

Hi again,

I tried looking into the build log, but the missing dependencies seem to be non-essential to the missing boxes:

Code: Select all

$ grep -i fail rebuild.log 
--   FAILED to find liblsl (optional) ...
--   FAILED to find VRPN
--   FAILED to find Emotiv API (optional driver)
--   FAILED to find MindMedia NeXus device dll (optional driver)
--   FAILED to find MCS device SDK (optional driver)
--   FAILED to find Mensia Acquisition driver (optional driver)
--   FAILED to find Micromed device dlls (optional driver)
--   FAILED to find TMSi device dll (optional driver)
--   FAILED to find EEGO API (optional driver) - cmake looked in '/home/xskola/dev/openvibe-2.0.1-src/dependencies/home/xskola/dev/openvibe-2.0.1-src/extras/dependencies', skipping EEGO.
--   FAILED to find GMobiLabPlusAPI... (optional driver)
--   FAILED to find GUSBAmpAPI Linux... (optional)
--   FAILED to find Mitsar device dll (optional driver)
The full log file is here: https://www.fi.muni.cz/~xskola/rebuild.log. If you see anything suspicious there, please throw your ideas! Thanks a lot!

Filip

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Missing boxes after compiling on Linux

Post by jtlindgren »

Hi,

that is quite odd, nothing in your log explains it. A colleague was suggesting that maybe its loading the libs from another location due to some previous build or something? When you launch Designer, what does it print? Can you copy paste here? Also, it'd be useful to have a full log of a clean build (delete build/ and dist/ and run build.sh again while redirecting to a file, i.e. build.sh >dump.txt).


Cheers,
Jussi

xskola
Posts: 12
Joined: Tue Mar 13, 2018 12:39 pm

Re: Missing boxes after compiling on Linux

Post by xskola »

The library location should be clear (empty LD_LIBRARY_PATH), previous builds are not installed on the computer. I tried the clean build, the log is here: https://www.fi.muni.cz/~xskola/build.log.

The following is the output from running openvibe-designer.sh:

Code: Select all

2345 (process ID) old priority 0, new priority 19
[  INF  ] Created kernel loader, trying to load kernel module
[  INF  ] Kernel module loaded, trying to get kernel descriptor
[  INF  ] Got kernel descriptor, trying to create kernel
[  INF  ] Adding kernel configuration file [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/kernel/openvibe.conf]
[  INF  ] Logging to '/home/xskola/.config/openvibe-2.0/log/openvibe-designer.log'
[  INF  ] Syntax :
[  INF  ] Adding plugins from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-*.so]
[  INF  ] Added 17 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-advanced-visualization.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-examples.so]
[  INF  ] Added 3 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-designer-simple-visualization.so]
[  INF  ] Added 10 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-classification.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-data-generation.so]
[  INF  ] Added 1 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-feature-extraction.so]
[  INF  ] Added 9 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-file-io.so]
[  INF  ] Added 24 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-signal-processing.so]
[  INF  ] Added 5 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-stimulation.so]
[  INF  ] Added 19 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-stream-codecs.so]
[  INF  ] Added 2 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-streaming.so]
[  INF  ] Added 3 plugin object descriptor(s) from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/lib/libopenvibe-plugins-sdk-tools.so]
[  INF  ] Adding metaboxes from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/metaboxes/;/home/xskola/.config/openvibe-2.0/metaboxes/]
[  INF  ] Added 0 metaboxes from [/home/xskola/dev/openvibe-2.0.1-clean/dist/designer-Release/share/openvibe/metaboxes/]
[  INF  ] Added 0 metaboxes from [/home/xskola/.config/openvibe-2.0/metaboxes/]
[  INF  ] Initialization took 134 ms
[  INF  ] Application terminated, releasing allocated objects
Plus also attaching the detailed log from $home/.config in case this is helpful.
Attachments
openvibe-designer.log
(18.58 KiB) Downloaded 110 times

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Missing boxes after compiling on Linux

Post by jtlindgren »

Ah, now its becoming more clear! The reason is probably that you run Designer from its own sub-distribution. To get all the modules that correspond to the full openvibe distribution, you need to launch it from 'dist/extras-Release/'. Can you try that and let me know if it works?

Cheers,
Jussi

xskola
Posts: 12
Joined: Tue Mar 13, 2018 12:39 pm

Re: Missing boxes after compiling on Linux

Post by xskola »

Oh my, such a stupid mistake! Thanks a ton, I run the script from extras-Release and everything seems to work like a charm now.

Post Reply