OpenViBE forum

The OpenViBE community
It is currently Thu Dec 14, 2017 10:08 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue May 24, 2016 3:41 am 
Offline

Joined: Wed May 18, 2016 8:43 pm
Posts: 16
I've tried to compile the code after following all the steps illustrated in the manual. However, the building was never completed.

OS: windows 8
VS: 2010

The log:

Code:
[ 72%] Built target openvibe-examples-openvibe-to-vrpn
[ 73%] Built target openvibe-examples-vrpn-to-openvibe
Linking CXX executable openvibe-acquisition-server.exe
LINK : warning LNK4199: /DELAYLOAD:edk.dll ignored; no imports found from edk.dl
l
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EmoEngineEventFree referenced in function "public: virtual bool __thiscall O
penViBEAcquisitionServer::CDriverEmotivEPOC::uninitialize(void)" (?uninitialize@
CDriverEmotivEPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EngineDisconnect referenced in function "public: virtual bool __thiscall Ope
nViBEAcquisitionServer::CDriverEmotivEPOC::uninitialize(void)" (?uninitialize@CD
riverEmotivEPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EngineConnect referenced in function "public: virtual bool __thiscall OpenVi
BEAcquisitionServer::CDriverEmotivEPOC::initialize(unsigned int,class OpenViBEAc
quisitionServer::IDriverCallback &)" (?initialize@CDriverEmotivEPOC@OpenViBEAcqu
isitionServer@@UAE_NIAAVIDriverCallback@2@@Z)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EmoEngineEventCreate referenced in function "public: virtual bool __thiscall
 OpenViBEAcquisitionServer::CDriverEmotivEPOC::initialize(unsigned int,class Ope
nViBEAcquisitionServer::IDriverCallback &)" (?initialize@CDriverEmotivEPOC@OpenV
iBEAcquisitionServer@@UAE_NIAAVIDriverCallback@2@@Z)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataSetBufferSizeInSec referenced in function "public: virtual bool __thisca
ll OpenViBEAcquisitionServer::CDriverEmotivEPOC::start(void)" (?start@CDriverEmo
tivEPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataCreate referenced in function "public: virtual bool __thiscall OpenViBEA
cquisitionServer::CDriverEmotivEPOC::start(void)" (?start@CDriverEmotivEPOC@Open
ViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataGet referenced in function "public: virtual bool __thiscall OpenViBEAcqu
isitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotivEPOC@OpenViBEA
cquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataGetNumberOfSample referenced in function "public: virtual bool __thiscal
l OpenViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotiv
EPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataUpdateHandle referenced in function "public: virtual bool __thiscall Ope
nViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotivEPOC@
OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataAcquisitionEnable referenced in function "public: virtual bool __thiscal
l OpenViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotiv
EPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EmoEngineEventGetUserId referenced in function "public: virtual bool __thisc
all OpenViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmot
ivEPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EmoEngineEventGetType referenced in function "public: virtual bool __thiscal
l OpenViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotiv
EPOC@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_EngineGetNextEvent referenced in function "public: virtual bool __thiscall O
penViBEAcquisitionServer::CDriverEmotivEPOC::loop(void)" (?loop@CDriverEmotivEPO
C@OpenViBEAcquisitionServer@@UAE_NXZ)
ovasCDriverEmotivEPOC.cpp.obj : error LNK2019: unresolved external symbol __imp_
_EE_DataFree referenced in function "public: virtual bool __thiscall OpenViBEAcq
uisitionServer::CDriverEmotivEPOC::stop(void)" (?stop@CDriverEmotivEPOC@OpenViBE
AcquisitionServer@@UAE_NXZ)
ovasCAcquisitionServerGUI.cpp.obj : error LNK2019: unresolved external symbol "p
ublic: __thiscall OpenViBEAcquisitionServer::CDriverTMSiRefa32B::CDriverTMSiRefa
32B(class OpenViBEAcquisitionServer::IDriverContext &)" (??0CDriverTMSiRefa32B@O
penViBEAcquisitionServer@@QAE@AAVIDriverContext@1@@Z) referenced in function "pu
blic: __thiscall OpenViBEAcquisitionServer::CAcquisitionServerGUI::CAcquisitionS
erverGUI(class OpenViBE::Kernel::IKernelContext const &)" (??0CAcquisitionServer
GUI@OpenViBEAcquisitionServer@@QAE@ABVIKernelContext@Kernel@OpenViBE@@@Z)
openvibe-acquisition-server.exe : fatal error LNK1120: 15 unresolved externals
LINK failed. with 2
NMAKE : fatal error U1077: 'C:\Users\Y\Desktop\openvibe-1.2.0-src\dep
endencies\cmake\bin\cmake.exe' : return code '0xffffffff'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0
\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0
\VC\BIN\nmake.exe"' : return code '0x2'
Stop.

An error occured during building process

Press any key to continue . . .


any one might know how can this be solved?


Top
 Profile  
Reply with quote  
PostPosted: Mon May 30, 2016 6:44 am 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 599
Location: INRIA Rennes, FRANCE
Hi, it looks like there's some problem compiling the emotiv driver. One option is to disable the detection of that driver from the FindThirdPartyEmotiv-script, or if the os-level driver version you have installed is unsupported, you can downgrade it, uninstall it, or fix the openvibe side of the driver.

We're not currently looking into it at the core team though. Our access to the newer emotiv drivers is "rather limited", the main reason why Openvibe emotiv support is for an older version.


Cheers,
Jussi


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 24, 2016 2:16 am 
Offline

Joined: Wed May 18, 2016 8:43 pm
Posts: 16
jtlindgren wrote:
Hi, it looks like there's some problem compiling the emotiv driver. One option is to disable the detection of that driver from the FindThirdPartyEmotiv-script, or if the os-level driver version you have installed is unsupported, you can downgrade it, uninstall it, or fix the openvibe side of the driver.

We're not currently looking into it at the core team though. Our access to the newer emotiv drivers is "rather limited", the main reason why Openvibe emotiv support is for an older version.


Cheers,
Jussi


I used another OS - Windows 7- and it worked just fine.
Thank you for the reply.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.