Error during win32-build.cmd

Post Reply
Shodan
Posts: 2
Joined: Wed Jul 15, 2015 11:58 am

Error during win32-build.cmd

Post by Shodan »

Hi all.

I'm trying to build OpenVibe on a Win7 x64 with VS2013, I've installed a version cmake (3.2.2) that works with VS2013 compiler (12.0), I've run win32-install_dependencies.cmd and after that manually tweaked some make files one at a time to shoot down the "not found" errors, but there still remain a few last not found errors that were there before but I don't know which make files to tweak 'cause I don't know what these modules are and where to get them:

-- FAILED to find inpout32 (optional), parallel port tagging support disabled
-- FAILED to find inpout32 (optional), parallel port tagging support disabled
-- FAILED to find presage (optional), P300 word prediction disabled
-- Found required headers for External P300 Stimulator...
-- [FAILED] lib GLFW
-- [ OK ] lib C:/Program Files (x86)/Windows Kits/8.1/Lib/winv6.3/um/x86/O
penGL32.Lib
-- Did not find all required headers and/or libs for the External P300 Stimula
tor...

and then at the end:

-- Configuring incomplete, errors occurred!
See also "D:/openvibe-1.0.1-src/local-tmp/nmake-Release/CMakeFiles/CMakeOutput.l
og".

An error occured during building process

I couldn't make much sense of the specified log file, but it didn't contain any explicit error messages.

If the libraries that the script failed to find are optional - why does the build fail? I have no idea what is inpout32 or presage, but I'm pretty sure I don't need parallel port tagging support or P300 word prediction - all I need is to be able to build OpenVibe from sources, so that later I can write a custom signal processing module for it and compile with it added.

Any help would be appreciated. Thank you!

nfoy
Posts: 40
Joined: Fri Nov 14, 2014 1:06 pm

Re: Error during win32-build.cmd

Post by nfoy »

Dear Shodan,

inpout32 and presage libraries are optional indeed. This means that if these libraries are not found, the parts of the software using these libraries will be deactivated. These libraries are used by the coadapt P300 speller only, so if you're not using it, it won't impact you at all.

I think that your problem is due to something else. Beware that OpenVibe doesn't support VS2013 yet, and that VS2010 should be used to compile from the source.

Regards

Shodan
Posts: 2
Joined: Wed Jul 15, 2015 11:58 am

Re: Error during win32-build.cmd

Post by Shodan »

Thank you!
Would you recommend uninstalling VS2013 before installing VS2010? Would there be problems if I install 2010 in addition to 2013?

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Error during win32-build.cmd

Post by jtlindgren »

Hello Shodan, about VS, this seems more a question to Microsoft than to us. I have 2010 and 2012 at least on the
same computer without them interfering with one another, but who knows.


Cheers,
Jussi

Post Reply