OpenViBE forum
http://openvibe.inria.fr/forum/

Cognionics driver
http://openvibe.inria.fr/forum/viewtopic.php?f=4&t=9284
Page 1 of 1

Author:  barten6 [ Tue May 13, 2014 11:28 pm ]
Post subject:  Cognionics driver

Hi,
I have HW CogMini 2 170 and Driver SW openvibe-0.15.0-svn3402-src and
openvibe-0.17.1-src_cognionics from Cognionics, PCs with Win7 and Vista.

openvibe-0.15.0-svn3402-src does not allow the use of OV-designer 0.17.1, and
openvibe-0.17.1-src_cognionics stops execution of ov-acquisition-server.cmd with error „libgtk-win32-2.0-0.dll not found“, and execution of ov-designer.cmd with error „libexpat.dll not found“.

Both files, however, can be found at different Locations on the Computer.

Then:
1. which Versions of SDK-platform.NET and VisualC++..Redist do you recomend to download from MS?
2. into which Folders should I copy the 2 files which are not found at execution time?
3. do you think that these Problems might be solved with the new OV-release (June 2014? do you already have a more precise target date?) without requiring additional Support from Cognionics?

Hoping you can give me some advice basing on these bits and pieces,
best regards

Peter

Author:  jtlindgren [ Wed May 14, 2014 9:26 am ]
Post subject:  Re: Cognionics driver

Hi Peter,

in the first place, I don't understand why you are using version 0.15 for something? Although some openvibes might be compatible across versions, we recommend not to mix them.

Second, as we don't have the Cognionics hardware here at Inria, Openvibe team at Inria cannot provide support for the driver now or in the future. I recommend you contact the original author. This is the case for all contributed drivers.

In the official openvibe release, the installation should take care of all the dependencies and you shouldn't need to do any installing by hand. Concerning packages downloaded from somewhere else than the openvibe web site, you should contact the provider of that package. These people might or might not follow this forum, it's entirely up to them. :)


Cheers,
Jussi

Author:  barten6 [ Wed May 14, 2014 9:13 pm ]
Post subject:  Re: Cognionics driver

jtlindgren wrote:
in the first place, I don't understand why you are using version 0.15 for something? Although some openvibes might be compatible across versions, we recommend not to mix them.

..simply because Cognionics has a working 0.15-driver, but no 0.17. I#m not willing to mix versions- its pure Desperation.

barten6 wrote:
. which Versions of SDK-platform.NET and VisualC++..Redist do you recomend to download from MS?

I don't find a corresponding advice in your Installation recommendations, that's why I'm asking...

barten6 wrote:
do you think that these Problems might be solved with the new OV-release (June 2014? do you already have a more precise target date?)

can you give me some prospect?

Tnx and rds,
Peter

Author:  jtlindgren [ Thu May 15, 2014 7:22 am ]
Post subject:  Re: Cognionics driver

Just out of curiosity, where are these "openvibe-0.15.0-svn3402-src and openvibe-0.17.1-src_cognionics from Cognionics, PCs with Win7 and Vista." provided?

In any case, as we are not planning any changes to the Cognionics driver part for 0.18, you might as well try the openvibe git version.

Use the information here,

http://openvibe.inria.fr/repo-instructions/
http://openvibe.inria.fr/build-instructions/


Best,
Jussi

Author:  barten6 [ Thu May 15, 2014 2:27 pm ]
Post subject:  Re: Cognionics driver

uffa!
well, the pieces of SW stem from Cognionics- I don't know, where they got them from. Is that what you wanted to know, or should I try to find out more Details?

jtlindgren wrote:
In any case, as we are not planning any changes to the Cognionics driver part for 0.18, you might as well try the openvibe git version.


I'm not sure if I understood well:
when you say "we are not planning any changes to the Cognionics driver part for 0.18" , I understand, that there IS such a Driver in 0.18. Is that correct? In this case, I would be happy to learn, WHEN it can become available for me.
Is it also correct, that you DON'T have a Cognionics Driver in 0.17?
What exactly includes the openvibe git Version- is it 0.17 or 0.18, with or without Cognionics Driver, and is it simply compilable or must it be enhanced by some 3rd Party code?
(you see, I'm totally lost- may be you can enlight me....).
best rds
Peter

Author:  jtlindgren [ Thu May 15, 2014 3:33 pm ]
Post subject:  Re: Cognionics driver

This is how it goes.

1) official 0.17.x does not have a cognionics driver.
2) current git version has a contributed cognionics driver.
3) official 0.18 will have a contributed cognionics driver. It should be out in June.

'git' version means the current work in progress code available by the instructions in the repo link I posted. Once we have worked enough on the features of the git version, we take a snapshot of its 'master' branch and call it 0.18. Then, the git version will again progress day by day and eventually turn into 0.19, etc.

By 'official' I mean the openvibes released by Inria at the openvibe.inria.fr site.


Hope this helps,
Jussi

Author:  barten6 [ Thu May 15, 2014 9:12 pm ]
Post subject:  Re: Cognionics driver

...you bet it does.
tnx a lot, Jussi!
Only Thing left:
jtlindgren wrote:
barten6 wrote:. which Versions of SDK-platform.NET and VisualC++..Redist do you recomend to download from MS?I don't find a corresponding advice in your Installation recommendations, that's why I'm asking...

where can i find instructions?
bonne nuit
Peter

Author:  jtlindgren [ Fri May 16, 2014 7:29 am ]
Post subject:  Re: Cognionics driver

Please explain the problem. OpenViBE dependency installer downloads the required components. If you think there is a bug, please follow the bug reporting instructions in the FAQ and provide exact, minute steps to reproduce. Again, I can myself only respond to questions concerning OpenViBE releases by Inria.

http://openvibe.inria.fr/faq/


Best,
Jussi

Author:  barten6 [ Sat May 17, 2014 11:32 am ]
Post subject:  Re: Cognionics driver

tnx for the clear answer, Jussi.
everything fine, no bug in sight!
best rds
Peter

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/