OpenViBE forum

The OpenViBE community
It is currently Fri Dec 15, 2017 9:37 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Build on Ubuntu14.04
PostPosted: Tue May 13, 2014 11:51 am 
Offline

Joined: Tue May 13, 2014 10:07 am
Posts: 4
Hello everyone,
I just start a new internship and I need tu install openvibe on ubuntu14.04.
First I couldn't install the depedencies with "linux-install_dependencies" beceause libogre-dev was obsolete.
I installed with "apt-get install libogre-1.8-dev" the new library

But now I still can't build the software. There is trouble with the boost library. It can't find a path for boost_system-mt, boost_system_regex...
I had these errors. I'm a beginner with Unix... Thanks for your help.

Code:
../libopenvibe-module-fs.so.0.17.1: référence indéfinie vers « boost::filesystem::path::parent_path() const »
../libopenvibe-module-fs.so.0.17.1: référence indéfinie vers « boost::system::system_category() »
../libopenvibe-module-fs.so.0.17.1: référence indéfinie vers « boost::filesystem::detail::create_directories(boost::filesystem::path const&, boost::system::error_code*) »
../libopenvibe-module-fs.so.0.17.1: référence indéfinie vers « boost::system::generic_category() »
collect2: error: ld returned 1 exit status
make[2]: *** [modules/fs/test/test_fs] Erreur 1
make[1]: *** [modules/fs/test/CMakeFiles/test_fs.dir/all] Erreur 2


Top
 Profile  
Reply with quote  
 Post subject: Re: Build on Ubuntu14.04
PostPosted: Tue May 13, 2014 12:57 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 601
Location: INRIA Rennes, FRANCE
Hello yneveu,

You do not mention which version of openvibe you are trying. The last release version 0.17 might not compile. However, there are changes in the git version, and that should already work on 14.04 without having to install any packages by hand. The dependency script should do everything.

If you haven't already, please give the git version a try.

Good luck,
Jussi


Top
 Profile  
Reply with quote  
 Post subject: Re: Build on Ubuntu14.04
PostPosted: Tue May 13, 2014 4:30 pm 
Offline

Joined: Tue May 13, 2014 10:07 am
Posts: 4
This is the 0.17.1 version.

When I try to build, it can't find some libraries from boost. (boost_thread-mt, boost_filesystem-mt...)
I change the CMake files and now it search (boost_thread and boost_file_system) instead of (boost_thread-mt...)

Before he stoped at 7% now he's still building.

I will give you more information if that works entirely.


Top
 Profile  
Reply with quote  
 Post subject: Re: Build on Ubuntu14.04
PostPosted: Wed May 14, 2014 12:07 pm 
Offline

Joined: Tue May 13, 2014 10:07 am
Posts: 4
install completed. There is no '-mt' in the name of the library. This is maybe an explanation

http://stackoverflow.com/questions/3031 ... -thread-mt


Top
 Profile  
Reply with quote  
 Post subject: Re: Build on Ubuntu14.04
PostPosted: Wed May 14, 2014 2:07 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 601
Location: INRIA Rennes, FRANCE
Thanks for the report! Our git version has been modified to alternatively look for the libs without the postfixes.

Hope it works for you now.

Happy hacking,
Jussi


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maël Soucaze.