OpenViBE forum

The OpenViBE community
It is currently Wed Sep 18, 2019 11:43 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Jun 03, 2011 7:37 am 
Offline

Joined: Mon May 30, 2011 6:32 pm
Posts: 14
Hi all,

after the dependencies have been installed/compiled successfully, I tried to compile openvibe (Rev: 2993) on Debian lenny 32bit.

The module simple_visualisation, OpenViBE-designer-dynamic and possibly other fail building with the error:
Quote:
Building CXX object CMakeFiles/OpenViBE-plugins-simple-visualisation-dynamic.dir/src/ovp_main.o
/home/alexp/soft/openvibe/trunk/openvibe-plugins/simple-visualisation/trunc/src/ovpCBoxAlgorithmMatrixDisplay.cpp: In member function ‘virtual OpenViBE::boolean OpenViBEPlugins::SimpleVisualisation::CBoxAlgorithmMatrixDisplay::process()’:
/home/alexp/soft/openvibe/trunk/openvibe-plugins/simple-visualisation/trunc/src/ovpCBoxAlgorithmMatrixDisplay.cpp:179: error: ‘gtk_widget_set_visible’ was not declared in this scope
/home/alexp/soft/openvibe/trunk/openvibe-plugins/simple-visualisation/trunc/src/ovpCBoxAlgorithmMatrixDisplay.cpp:203: error: ‘gtk_widget_set_visible’ was not declared in this scope
/home/alexp/soft/openvibe/trunk/openvibe-plugins/simple-visualisation/trunc/src/ovpCBoxAlgorithmMatrixDisplay.cpp:228: error: ‘gtk_widget_set_visible’ was not declared in this scope


I tried not to use the native packages (compile from source) for
# ov_hit_package "glib"
# ov_hit_package "cairo"
# ov_hit_package "pango"
# ov_hit_package "atk"
# ov_hit_package "gtk"
# ov_hit_package "clearlooks"
# ov_hit_package "libglade"
# ov_hit_package "glade"

this did not solve the problem.
Any hint where this comes from?
Thank you
Alex


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 03, 2011 9:02 am 
Offline

Joined: Mon May 30, 2011 6:32 pm
Posts: 14
with the version from the download page (openvibe-0.10.0)

simple visual compiles, but OpenViBE-designer-dynamic shows the above reported problem. All other modules compile.

Any hints?

Alex


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 03, 2011 12:02 pm 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear alexp,

according to GTK documentation, gtk_widget_set_visible has been available since GTK 2.18 which is pretty old. What version of GTK do you have in your debian lenny ?

Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 03, 2011 12:51 pm 
Offline

Joined: Mon May 30, 2011 6:32 pm
Posts: 14
Dear Yann,

my system has 2.12.12. I also tried to compile from source in linux-install_dependencies. Now I have seen, that it downloads an even older version, namely
Quote:
ov_package_url_gtk=$ov_gnome_mirror/sources/gtk+/2.12/gtk+-2.12.11.tar.bz2


Seems that linux-install_dependencies is not up to date for the source packages...
Can I find a list of current dependencies anywhere?

Alex


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 03, 2011 1:20 pm 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear alexp,

linux dependencies installation script is indeed not up to date when it comes to complete build from sources, this is not supposed to be used and is only devoted to ninja linux users ;)

would it be an option to upgrade your system to squeeze for instance (give it a try in a virtual machine first) ? This would probably be the easiest way to make things work again on this pretty old distro. Alternatively, if you want to keep lenny, you'll indeed have to patch the installation script in order to install more recent versions of GTK and probably of its dependencies as well. This is quite a piece of work, believe me ;)

Hope this helps,
Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 04, 2011 9:37 am 
Offline

Joined: Mon May 30, 2011 6:32 pm
Posts: 14
Hi Yann,

I made some further tests, but you are right - resolving all dependencies from source is a lot of work. I updated my system (on a test machine) to squeeze - there openvibe compiles.
Thank you!

Alex


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maël Soucaze.