OpenViBE forum

The OpenViBE community
It is currently Sat Dec 16, 2017 8:38 pm

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Feb 03, 2011 2:23 pm 
Offline

Joined: Sun Mar 14, 2010 12:58 pm
Posts: 108
Hi guys,

I am trying to install OpenViBE on my machine (x86_64, Ubuntu 10.10, gcc 4.4.5), and I got an error while building CEGUI with the linux-install-dependancies script.
Here is the error I got (from file cegui.log):

Code:
make[4]: entrant dans le répertoire « /home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui/src/ImageCodecModules/DevILImageCodec »
/bin/bash ../../../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../../../../cegui/include -I../../../../cegui/include -I../../../../cegui/include/ImageCodecModules/DevILImageCodec -DUSE_DEVIL_LIBRARY  -I/home/fabien/code/trunk/scripts/software/include  -g -O2 -MT libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.lo -MD -MP -MF .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.Tpo -c -o libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.lo `test -f 'CEGUIDevILImageCodec.cpp' || echo './'`CEGUIDevILImageCodec.cpp
/bin/bash ../../../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../../../../cegui/include -I../../../../cegui/include -I../../../../cegui/include/ImageCodecModules/DevILImageCodec -DUSE_DEVIL_LIBRARY  -I/home/fabien/code/trunk/scripts/software/include  -g -O2 -MT libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.lo -MD -MP -MF .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.Tpo -c -o libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.lo `test -f 'CEGUIDevILImageCodecModule.cpp' || echo './'`CEGUIDevILImageCodecModule.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../../../../cegui/include -I../../../../cegui/include -I../../../../cegui/include/ImageCodecModules/DevILImageCodec -DUSE_DEVIL_LIBRARY -I/home/fabien/code/trunk/scripts/software/include -g -O2 -MT libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.lo -MD -MP -MF .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.Tpo -c CEGUIDevILImageCodec.cpp  -fPIC -DPIC -o .libs/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.o
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../../../../cegui/include -I../../../../cegui/include -I../../../../cegui/include/ImageCodecModules/DevILImageCodec -DUSE_DEVIL_LIBRARY -I/home/fabien/code/trunk/scripts/software/include -g -O2 -MT libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.lo -MD -MP -MF .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.Tpo -c CEGUIDevILImageCodecModule.cpp  -fPIC -DPIC -o .libs/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.o
mv -f .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.Tpo .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.Plo
mv -f .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.Tpo .deps/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.Plo
/bin/bash ../../../../libtool --tag=CXX   --mode=link g++  -g -O2 -release 0.7.1 -L/home/fabien/code/trunk/scripts/software/lib -L/home/fabien/code/trunk/scripts/software/lib64 -o libCEGUIDevILImageCodec.la -rpath /home/fabien/code/trunk/scripts/software/lib libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.lo libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.lo -lIL -lILU ../../../../cegui/src/libCEGUIBase.la -lglut -lGLU -lGL  -lSM -lICE 
libtool: link: warning: `/usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../../lib/libfreetype.la' seems to be moved
libtool: link: g++ -shared -nostdlib /usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../../lib/crti.o /usr/lib/gcc/x86_64-linux-gnu/4.4.5/crtbeginS.o  .libs/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodec.o .libs/libCEGUIDevILImageCodec_la-CEGUIDevILImageCodecModule.o   -Wl,-rpath -Wl,/home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui/src/.libs -Wl,-rpath -Wl,/home/fabien/code/trunk/scripts/software/lib -L/home/fabien/code/trunk/scripts/software/lib -L/home/fabien/code/trunk/scripts/software/lib64 -L/usr/lib /usr/lib/libILU.so /usr/lib/libIL.so /usr/lib/libtiff.so -lpng12 -lmng /usr/lib/liblcms.so /usr/lib/libjpeg.so -lXpm -lXcursor -lpthread -ldl -lXxf86vm ../../../../cegui/src/.libs/libCEGUIBase.so -L/usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../../lib /usr/lib/libfreetype.so -lz -lpcre -lglut -lGLU -lGL -lSM -lICE -L/usr/lib/gcc/x86_64-linux-gnu/4.4.5 -L/lib/../lib -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-linux-gnu/4.4.5/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../../lib/crtn.o    -Wl,-soname -Wl,libCEGUIDevILImageCodec-0.7.1.so -o .libs/libCEGUIDevILImageCodec-0.7.1.so
/usr/bin/ld: cannot find -lmng
collect2: ld returned 1 exit status
make[4]: *** [libCEGUIDevILImageCodec.la] Erreur 1
make[4]: quittant le répertoire « /home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui/src/ImageCodecModules/DevILImageCodec »
make[3]: *** [all-recursive] Erreur 1
make[3]: quittant le répertoire « /home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui/src/ImageCodecModules »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/fabien/code/trunk/scripts/software/tmp/CEGUI-0.7.1/cegui »
make: *** [all-recursive] Erreur 1
~/code/trunk/scripts/software/tmp ~/code/trunk/scripts


It seems I am missing the "mng" library, is that right? If it is the case, maybe this library should be added to the dependencies as well?
What do you think?

thank you in advance!

Regards,
Fabien


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 03, 2011 3:57 pm 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear fabien,

actually, this dependency is not installed by the linux-install_dependency but is a direct dependency of GIMP which should be pre-installed on Ubuntu (as far as I know). Could you check if this library is actually missing on your system or maybe it is just not found by CEGUI at build time ?

Thank you,
Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Wed Feb 16, 2011 1:01 pm 
Offline

Joined: Sun Mar 14, 2010 12:58 pm
Posts: 108
Dear Yann,

Thank you for your help! MNG was indeed already installed as you guessed and LD was just unable to find it, for two reasons:
- I didn't check my LD_LIBRARY_PATH variable, and it was actually empty (I am a noob :-)) so it could'nt find MNG which was naturally in usr/lib
- the library was named "libmng.so.1" but there was no symbolic link named "libmng.so", so again LD couldn't find it. I just added this link to solve the problem.

I had the same problem with libXxf86vm, which was of course solved using the same approach. I now have a fully functional and working OpenViBE! Yes!

Thanks again.

Regards,
Fabien


Top
 Profile  
Reply with quote  
PostPosted: Wed Feb 16, 2011 2:06 pm 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear Fabien,

did you build all the dependencies from sources ? I mean if you are using any ubuntu derivate, you should better install native packages, definitely !

Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 20, 2012 3:56 pm 
Offline

Joined: Fri Apr 20, 2012 3:43 pm
Posts: 1
Hello all,

I tried to install openvibe 0.13.1 in my Ubuntu 10.04(LTS) 64 bit but I ended up getting the following error.. I tried the solutions of Fabien but still couldnt figure out the problem....

Trying to install package [cegui]...
Downloading [http://sourceforge.net/projects/crayzedsgui/files/CEGUI%20Mk-2/0.7.1/CEGUI-0.7.1.tar.gz] as [CEGUI-0.7.1.tar.gz]...
Downloading [http://sourceforge.net/projects/crayzedsgui/files/CEGUI%20Mk-2/0.7.1/CEGUI-0.7.1.tar.gz] succeeded... (cached)
Uncompressing [/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/arch/CEGUI-0.7.1.tar.gz]...
Uncompressing [/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/arch/CEGUI-0.7.1.tar.gz] succeeded...
Configuring [cegui]...
Configuring [cegui] succeeded...
Building [cegui]...
Building [cegui] failed !
Log file can be found at [/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/log/cegui.log] and ends with :

make[4]: *** [libCEGUITinyXMLParser_la-CEGUITinyXMLParser.lo] Error 1
make[4]: Leaving directory `/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/tmp/CEGUI-0.7.1/cegui/src/XMLParserModules/TinyXMLParser'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/tmp/CEGUI-0.7.1/cegui/src/XMLParserModules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/tmp/CEGUI-0.7.1/cegui/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/tmp/CEGUI-0.7.1/cegui'
make: *** [all-recursive] Error 1
~/openvibe-0.13.1-svn3210-src/scripts/software/tmp ~/openvibe-0.13.1-svn3210-src/scripts


Could anyone throw more light on the problem.....

Regards
Ramesh


Top
 Profile  
Reply with quote  
PostPosted: Thu May 03, 2012 4:06 pm 
Offline

Joined: Tue Nov 02, 2010 8:51 am
Posts: 239
Location: Mensia Technologies Paris FR
Hello Ramesh,

have you managed to resolve your issue?

If not, could you please post the whole logfile? it is located at /home/rnatar609/openvibe-0.13.1-svn3210-src/scripts/software/log/cegui.log . Since the output from the terminal is only the last part of the file. I have tried compiling OpenViBE dependencies on a fresh 10.04-64bit just now and it worked.

Cheers
Jozef

_________________
My Weblog Follow me on Twitter


Top
 Profile  
Reply with quote  
PostPosted: Tue May 21, 2013 7:41 am 
Offline

Joined: Tue May 21, 2013 7:25 am
Posts: 1
I had the same problem just now when I tried to install the current latest version (3676) on ubuntu 12.04. I managed to solve it by installing lua before running the linux-install-dependencies script. ( apt-get install lua5.1 to be precise.)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maël Soucaze.