OpenViBE forum

The OpenViBE community
It is currently Wed Sep 18, 2019 11:20 am

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: DRIVER for Emotiv Epoch
PostPosted: Thu Jan 20, 2011 8:13 pm 
Offline

Joined: Sat Jan 15, 2011 7:25 pm
Posts: 6
Does anyone have a driver for the emotiv epoch EEG headset for OpenVibe? I am new to this and I'm having trouble with the baby steps....

Could anyone, also, give me a brief walk-through in how to apply and set up the driver to get the system working.

Thanks a million.

Tiernan :?:


Top
 Profile  
Reply with quote  
PostPosted: Fri Jan 21, 2011 10:03 am 
Offline
Site Admin

Joined: Wed Oct 07, 2009 12:11 pm
Posts: 417
Hello Tiernan and welcome on board.

As stated in the FAQ, or in this post, we provide an OpenViBE driver for the Emotiv EPOC, but only if you have the Research Edition and build openvibe from sources.
I hope the documentation pages will be ok for you :)

Cheers,

Laurent

_________________
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 13, 2011 8:23 am 
Offline

Joined: Wed Apr 13, 2011 8:09 am
Posts: 9
I have the same problem and no idea where to start :) I need the driver for Emotiv but compiling from sources seems like a daunting task. Help ;)


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 13, 2011 11:44 am 
Offline
Site Admin

Joined: Wed Oct 07, 2009 12:11 pm
Posts: 417
Hi juxachim and welcome on board !

We know that compiling openvibe from sources may sound tricky for people who don't have any computer programming culture.
Anyway, it is the only way to get a driver for the Emotiv EPOC. This is the agreement we have with the Emotiv company : EPOC users may connect it with openvibe only if they have bought the Research Edition (or higher), and compile the software with it.

Buck up ! you can do it :)

If the documentation and the previous topics on the forum don't help, come back and I'll do my best to help you.
Please state all your problems with a precise context : what is your operating system (win xp, 7 ?) what did you do, on which step it fails ?
etc.

Cheers

Laurent-

_________________
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 13, 2011 12:06 pm 
Offline

Joined: Wed Apr 13, 2011 8:09 am
Posts: 9
Laurent, thanx for the cheering up :) I have some rudimentary programming skills from java a cpl of years ago, I installed visual C++ Express and I'm currently trying to find the sourcecode to download. I'll be compiling for win7, and I have the proper edition of the Epoch headset.

I'll sure give it a try! :)


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 13, 2011 1:56 pm 
Offline

Joined: Wed Apr 13, 2011 8:09 am
Posts: 9
I managed to compile the program!

But the openVibe aquisition-server does not list the epoch driver. What did I miss? I used the win32-build script. Do i need to add something to the env-command -file?


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2011 10:50 am 
Offline

Joined: Wed Apr 13, 2011 8:09 am
Posts: 9
juxachim wrote:
I managed to compile the program!

But the openVibe aquisition-server does not list the epoch driver. What did I miss? I used the win32-build script. Do i need to add something to the env-command -file?


Note to self and to others looking to build the emotiv driver, I found a rather helpful article here: http://hiran6.blogspot.com/2010/10/emotiv-driver-for-openvibe.html with step by step instructions. I'm still in the process so I don't know how the end result will be, but I'll notify :)

EDIT:

RESULT, compiler quits with the following error message:

Code:
Configuring and building openvibe-applications\acquisition-server\branches\wip-l
bonnet-emotiv ...

CMake Error: The source directory "C:/Ovib/openvibe-applications/acquisition-ser
ver/branches/wip-lbonnet-emotiv" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

An error occured during building process

Press any key to continue . . .


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2011 12:27 pm 
Offline

Joined: Thu Sep 02, 2010 2:43 pm
Posts: 78
Location: Université Libre de Bruxelles
juxachim wrote:
juxachim wrote:
I managed to compile the program!

But the openVibe aquisition-server does not list the epoch driver. What did I miss? I used the win32-build script. Do i need to add something to the env-command -file?


Note to self and to others looking to build the emotiv driver, I found a rather helpful article here: http://hiran6.blogspot.com/2010/10/emotiv-driver-for-openvibe.html with step by step instructions. I'm still in the process so I don't know how the end result will be, but I'll notify :)

EDIT:

RESULT, compiler quits with the following error message:

Code:
Configuring and building openvibe-applications\acquisition-server\branches\wip-l
bonnet-emotiv ...

CMake Error: The source directory "C:/Ovib/openvibe-applications/acquisition-ser
ver/branches/wip-lbonnet-emotiv" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

An error occured during building process

Press any key to continue . . .


The how to is out of date as it is not official. The emotiv driver has been moved to the trunc. Take a look at this discussion and I am sure you will be able to get it done -
viewtopic.php?f=14&t=311

_________________
Regards,

Karthik


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2011 12:35 pm 
Offline
Site Admin

Joined: Wed Oct 07, 2009 12:11 pm
Posts: 417
Hi all !

EDIT : thanks karthiks ;)

Quote:
Note to self and to others looking to build the emotiv driver, I found a rather helpful article here: http://hiran6.blogspot.com/2010/10/emot ... nvibe.html with step by step instructions. I'm still in the process so I don't know how the end result will be, but I'll notify :)


As I already said, this blog is an interesting contribution for the community. However, it is clearly out-of-date !
The error you mention :
Code:
CMake Error: The source directory "C:/Ovib/openvibe-applications/acquisition-server/branches/wip-lbonnet-emotiv" does not appear to contain CMakeLists.txt.

Happens because the branch wip-lbonnet-emotiv does not exist anymore. This branch was the "beta" version of the driver, wip meaning "work in progress" :)
Now that the driver is quiet stable, we moved it to the trunc of the acquisition server. It means that it is compiled when building the software from a fresh SVN checkout.
You don't need to change anything in the win32-init-env file.

- Do a fresh svn checkout.
- execute win32-install_dependencies.exe (check the compiler : visual studio 2008 or 2010, depending on your version)
- Check that the Emotiv Research SDK is present
- execute win32-build.cmd

Please look this post for an idea of what you should see when executing win32-build.cmd, and the common mistake made.

Hope this helps !

Laurent-

_________________
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maël Soucaze.