OpenViBE forum

The OpenViBE community
It is currently Wed Sep 18, 2019 11:28 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Aug 30, 2010 8:40 pm 
Offline

Joined: Sun Jun 27, 2010 3:44 pm
Posts: 27
Code:
Scanning dependencies of target OpenViBE-kernel-dynamic
[  1%] Building CXX object CMakeFiles/OpenViBE-kernel-dynamic.dir/src/openvibe-k
ernel/kernel/ovkCKernelObjectFactory.obj
ovkCKernelObjectFactory.cpp

d:\openv-useit\trunk\openvibe-kernel-omk\trunc\src\openvibe-kernel\kernel\visual
isation/ovkCVisualisationTree.h(9) : fatal error C1083: Cannot open include file
: 'gtk/gtk.h': No such file or directory

NMAKE : fatal error U1077: 'G:\PROGRA~1\MICROS~1.0\VC\bin\cl.exe' : return code
'0x2'
Stop.


This happen after installing the dependencies using win32-install_dependencies.exe. why is this? how do i resolve it?


Top
 Profile  
Reply with quote  
PostPosted: Tue Aug 31, 2010 7:44 am 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear jamesLocal,

I have moved your topic to the appropriate forum.

It looks like GTK is not found. If you did not reinstall the dependencies, please reinstall them (that means first your remove them, then you install them back). Once this is done, run win32-clean.cmd and win32-build.cmd again. This should solve your problem.

Tell me if it helps,
Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Fri Sep 03, 2010 5:03 am 
Offline

Joined: Sun Jun 27, 2010 3:44 pm
Posts: 27
Well, i did it several times, but it's the same :(


Top
 Profile  
Reply with quote  
PostPosted: Fri Sep 03, 2010 9:01 am 
Offline

Joined: Fri Jan 08, 2010 4:02 pm
Posts: 46
Dear jamesLocal,

I think the problem come to the win32-init_env_command.cmd. Have you got update this file with the newest skeleton file, because the "path" variable, define in this file have changed and the old "path" didn't contains the "gtk" path.
Can you copy the newest win32-init_env_command.cmd-skeleton to win32-init_env_command.cmd and build openvibe. I think, this should solve your problem.

Tell me if it helps,
Baptiste


Top
 Profile  
Reply with quote  
PostPosted: Fri Sep 03, 2010 9:42 am 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Thank you Baptiste, I did not realize that !

This change is due to the switch from glade to gtk.

Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.