OpenViBE forum

The OpenViBE community
It is currently Wed Sep 18, 2019 11:56 am

All times are UTC




Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Fri Dec 03, 2010 6:48 pm 
Offline

Joined: Mon Nov 15, 2010 4:45 pm
Posts: 3
Quote:
This problem means that the linker didn't found some functions, here in the itpp library (itpp is a dependence of openvibe, that we use for signal processing for example).

This error can occurs if you try to compile your project with one compiler while your dependency is compiled with another compiler.
Did you install the dependencies for VS2010 ? It's the first item to check in the list when running win32-install_dependencies.exe.

Cheers,

Laurent


Hi, Laurent

I followed the steps listed in FAQ, downloaded the latest source files from SVN, installed win32-install-dependencies.exe in scripts folder, then executed win-32-build...

I tried to change vs2010 to vs2008, though the build process can last much longer, but the same error occurred in the final. When I build the source files on WindowsXP with vs2008, it was ok, no errors.

Thank you for your reply.

Fei


Top
 Profile  
Reply with quote  
PostPosted: Wed Dec 08, 2010 8:27 am 
Offline
Site Admin

Joined: Wed Oct 07, 2009 12:11 pm
Posts: 417
I still think it may comes from compiler problem.

Do you have on your computer both visual studios ? (2008 & 2010)
If so, the win32-build script automatically uses the most recent compiler, in this case it would be VS2010.
If the dependencies are compiled with VS2008, it won't work.


Laurent-

_________________
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 10, 2010 10:01 am 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Dear wangfei0328,

did you successfully compile OpenViBE with either VS2008 or VS2010 ?

Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 14, 2010 9:52 pm 
Offline

Joined: Mon Nov 15, 2010 4:45 pm
Posts: 3
yrenard wrote:
Dear wangfei0328,

did you successfully compile OpenViBE with either VS2008 or VS2010 ?

Yann


Hi, Yann

I tried Win7+VS2008 and Win7+VS2010 separately, unfortunately, all failed. I have to give up because I have spent too much time on it. Now I change the OS to Windows XP, it works. :(


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 19, 2010 12:57 pm 
Offline
Site Admin

Joined: Fri Sep 01, 2006 3:39 pm
Posts: 645
Ok, thank you for your feedback
Yann

_________________
CTO at Mensia Technologies | Image my blog | Image my tweets | Image my linkedin


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maël Soucaze.