Tie Fighter Example - Getting Started

Working with OpenViBE signal processing scenarios and doing scenario/BCI design
Post Reply
image28
Posts: 2
Joined: Fri Oct 31, 2014 9:06 pm

Tie Fighter Example - Getting Started

Post by image28 »

I have the Olimex OpenEEG and have got it all connected and running.
I've loading the tie fighter demo and replacing the file reader component with the live signal input.
( Also tried with a recorded file )

However the tie fighter game just sits at READY?

I'm not 100% sure where to put the electodes... have 4 active and one passive.... I have been placing 2 electrodes around the Cz area, and labeling the channel Cz....

What other steps are required to get the demo running correctly.

Thanks,
Kevin Macey

fabien.lotte
Posts: 110
Joined: Sun Mar 14, 2010 12:58 pm

Re: Tie Fighter Example - Getting Started

Post by fabien.lotte »

Hi Kevin,

You could get the updated Tie-Fighter scenarios that we presented at the recent OpenViBE workshop, there:

1:30-2:15pm: Fabien Lotte, Alison Cellard, Inria Bordeaux Sud-Ouest, France, “Hands-on tutorial with actual EEG recordings: Motor Imagery-based BCI design“
pdf of the slides: http://openvibe.inria.fr/openvibe/wp-co ... tation.pdf
Demo : OpenViBE-workshop_spaceship-demo - openvibe scenarios: http://openvibe.inria.fr/openvibe/wp-co ... r-demo.zip

Hopefully it can answer your questions!

Let me know,

Best regards,
Fabien

image28
Posts: 2
Joined: Fri Oct 31, 2014 9:06 pm

Re: Tie Fighter Example - Getting Started

Post by image28 »

Thanks for the quick reply, will check out the slides and demo... Will post my results here afterwards...

AvivSheriff
Posts: 7
Joined: Wed May 11, 2016 8:41 am

Re: Tie Fighter Example - Getting Started

Post by AvivSheriff »

Hi Fabien, would it be possible to get the source code for the tie fighter/spaceship demo, so I can edit it on ogre3d to fit my project?

cremed
Posts: 3
Joined: Thu Jun 30, 2016 4:17 pm

Re: Tie Fighter Example - Getting Started

Post by cremed »

I have set up the tie fighter example based off the scenarios in the zip file and the slides provided. I am using an OpenBCI V3-32 board and online signals as my input. I am using FCz,C1,Cz,C2,and CPz However, the tie fighter game just sits at READY?

Any ideas on how to fix this?

Thanks,
Morgan

gqueneherve
Posts: 8
Joined: Sun Oct 29, 2017 9:54 am

Re: Tie Fighter Example - Getting Started

Post by gqueneherve »

Hi, in the paper « https://hal.archives-ouvertes.fr/hal-01366873 », an OpenVIBE scenario to calibrate the « Use-The-Force » game is mentioned.
How could I get this scenario ?
Regards,
Gilles

gqueneherve
Posts: 8
Joined: Sun Oct 29, 2017 9:54 am

Re: Tie Fighter Example - Getting Started

Post by gqueneherve »

gqueneherve wrote:Hi, in the paper « https://hal.archives-ouvertes.fr/hal-01366873 », an OpenVIBE scenario to calibrate the « Use-The-Force » game is mentioned.
How could I get this scenario ?
Regards,
Gilles
Forget this post : I've just seen that everything needed about Tie-Fighter demo is in the .zip archive just above in Fabien Lotte's post.

gqueneherve
Posts: 8
Joined: Sun Oct 29, 2017 9:54 am

Re: Tie Fighter Example - Getting Started

Post by gqueneherve »

Hello,

I have built a BCI based on a OpenBCI headset NovaIII and a 4 channel GANGLION.
I'm using OpenVibe 2.0 to process the signals.
Many thanks to Jelena Mladenovic for her tuto "Connect OpenBCI Ganglion with OpenVibe for Dummies".

These days, I'm trying to run the "OpenViBE Workshop - Tie-Fighter Demo" which was designed on OV 1.x.
To run it on OV2, I have made two kinds of changes :
- I replaced the obsolete blocks by the new ones ;
- As I only have 4 channels instead of 5, I modified the Laplacian parameters : 3 times Cz minus 3 other signals from the 3 other electrodes placed on FC1, FC2, CP1.

The "Use-the-force-online_5chanLaplacianCz_self-paced-session_OV2_4ch" seems to work.
But not the "threshold_movement_calibration_OV2_4ch" which causes errors.
The first error is related to the "Sound Player" block. See the snapshot enclosed.
I use OpenVibe 2.0.0 for Linux 64. But it is the same on Windows 10 64bits with OpenVibe 2.0.0 and OpenVibe 2.1.0.

Could you please help me fix the error caused by the "Sound Player" block ?

Best Regards,

Gilles.
Attachments
error snapshot
error snapshot
SoundPlayerBoxError2.png (136.5 KiB) Viewed 6694 times
Use-the-force-online_5chanLaplacianCz_self-paced-session_OV2_4ch.xml
(46.68 KiB) Downloaded 143 times
threshold_movement_calibration_OV2_4ch.xml
scenario
(58.78 KiB) Downloaded 146 times

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Tie Fighter Example - Getting Started

Post by jtlindgren »

Hi Gilles,

great to hear you're getting closer to get the workshop pkg to work on ov 2.0!

The issue you mention is probably due to the 'stop' stimulation field being empty in the sound player configuration. It seems the box requires a valid stimulation code specified in order to be happy.


Cheers,
Jussi

gqueneherve
Posts: 8
Joined: Sun Oct 29, 2017 9:54 am

Re: Tie Fighter Example - Getting Started

Post by gqueneherve »

Hi Jussi,

Thanks a lot for your help : the 'soundbox' box is now fixed.

I experience another error with the 'stimulation based epoching' box (see below the details).

Have any idea ?

Best regards,
Gilles

---------------------------------------------------------------------------------------------
[ WARNING ] Box <Sound Player> sends inconsistent chunk dates on output [0] (current chunk dates are [18446744073709551615,0] whereas previous chunk dates were [0,0])
[ WARNING ] 'Stimulations' streams should have continuously dated chunks
[ WARNING ] Please report to box author and attach your scenario
[ WARNING ] Box <Sound Player> sends inconsistent chunk dates on output [0] (current chunk dates are [18446744073709551615,0] whereas previous chunk dates were [0,0])
[ WARNING ] 'Stimulations' streams should have continuously dated chunks
[ WARNING ] Please report to box author and attach your scenario
[ INF ] At time 0.000 sec <Box algorithm::(0x6c0e485e, 0x30a96525) aka Lua Stimulator> Lua script terminated
[ WARNING ] At time 0.070 sec <Box algorithm::(0x179e376c, 0x68259698) aka Univariate Statistics> Output sampling Rate is null, it could produce problem in next boxes
[ ERROR ] At time 1.609 sec <Box algorithm::(0x2b08ed95, 0x74b91d79) aka Stimulation based epoching> {Error description} : {Stimulation Based Epoching can not work on overlapping signal}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {/home/openlab/openvibe/openvibe-2.0.0-src/sdk/plugins/processing/signal-processing/src/box-algorithms/epoching/ovpCBoxAlgorithmStimulationBasedEpoching.cpp::115}
[ ERROR ] {Error description} : {Box algorithm <Stimulation based epoching> processInput function failed}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {/home/openlab/openvibe/openvibe-2.0.0-src/sdk/kernel/src/kernel/player/ovkCSimulatedBox.cpp::230}
[ ERROR ] {Error description} : {Process failed for box with id (0x2b08ed95, 0x74b91d79)}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {/home/openlab/openvibe/openvibe-2.0.0-src/sdk/kernel/src/kernel/player/ovkCScheduler.cpp::620}
[ ERROR ] {Error description} : {Plugin object value is null}, {Error type} : {OpenViBE::Kernel::ErrorType::BadProcessing (code 6)}, {Error location} : {/home/openlab/openvibe/openvibe-2.0.0-src/sdk/kernel/src/kernel/plugins/ovkCPluginManager.cpp::340}

gqueneherve
Posts: 8
Joined: Sun Oct 29, 2017 9:54 am

Re: Tie Fighter Example - Getting Started

Post by gqueneherve »

Hi Jussi,
It's me again.
I managed to replay "workshop_calibration_example.ov" with "threshold_movement_calibration-replay" scenario in openvibe-designer 0.17.1 on windows 7.
But I didn't manage to replay "workshop_calibration_example.ov" with "threshold_movement_calibration_OV2-replay" scenario in openvibe-designer 2.0.1 on windows 7.
the scenarios are the same except the box versions.
I get an error on the stimulation based epoching box (see below).

I compared the source codes between version 1.0 and version 2.0 of this box. Version 2.0 seems to have 100% new code.
I wonder if box V2.0 can process "workshop_calibration_example.ov" ?

Could you please help me find a workaround to run the OpenViBE-workshop_tie-fighter-demo on OpenVibe V2.0 ?

Best regards,
Gilles

----------------------
[ WARNING ] At time 0.000 sec <Box algorithm::(0x4fd9d261, 0x1d053f7f) aka Sound Player> Unable to connect to AS's TCP Tagging plugin, stimuli wont be forwarded.
[ WARNING ] At time 0.000 sec <Box algorithm::(0x4068c52b, 0x23e3fa47) aka Sound Player> Unable to connect to AS's TCP Tagging plugin, stimuli wont be forwarded.
[ WARNING ] At time 0.000 sec <Box algorithm::(0x39855c6c, 0x7fd4b910) aka Display cue image> Unable to connect to AS's TCP Tagging plugin, stimuli wont be forwarded.
[ INF ] At time 0.000 sec <Box algorithm::(0x338bc3e3, 0x15acd56a) aka Generic stream reader> The file C:/UseTheForce/OpenViBE-workshop_tie-fighter-demo/signals/workshop_calibration_example.ov uses an outdated (but still compatible) version of the .ov file format
[ INF ] At time 0.000 sec <Box algorithm::(0x6c0e485e, 0x30a96525) aka Lua Stimulator> Lua script terminated
[ WARNING ] At time 0.086 sec <Box algorithm::(0x179e376c, 0x68259698) aka Univariate Statistics> Output sampling Rate is null, it could produce problem in next boxes
[ ERROR ] At time 1.625 sec <Box algorithm::(0x2b08ed95, 0x74b91d79) aka Stimulation based epoching> {Error description} : {Stimulation Based Epoching can not work on overlapping signal}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {C:\ovm\sdk\plugins\processing\signal-processing\src\box-algorithms\epoching\ovpCBoxAlgorithmStimulationBasedEpoching.cpp::116}
[ ERROR ] {Error description} : {Box algorithm <Stimulation based epoching> processInput function failed}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {C:\ovm\sdk\kernel\src\kernel\player\ovkCSimulatedBox.cpp::230}
[ ERROR ] {Error description} : {Process failed for box with id (0x2b08ed95, 0x74b91d79)}, {Error type} : {ErrorType::Internal (code 2)}, {Error location} : {C:\ovm\sdk\kernel\src\kernel\player\ovkCScheduler.cpp::687}
[ ERROR ] {Error description} : {Plugin object value is null}, {Error type} : {OpenViBE::Kernel::ErrorType::BadProcessing (code 6)}, {Error location} : {C:\ovm\sdk\kernel\src\kernel\plugins\ovkCPluginManager.cpp::340}
Attachments
threshold_movement_calibration_OV2-replay.xml
(54.14 KiB) Downloaded 126 times
threshold_movement_calibration-replay.xml
(53.68 KiB) Downloaded 146 times

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: Tie Fighter Example - Getting Started

Post by jtlindgren »

Hi,

I can understand debugging that scenario is made more difficult since there's many different error-like utterances.

First, I'd move "stimulation based epoching" before the "time based epoching" to get rid of the crucial error. The intended operation might change somewhat. The problem with the old ordering is that if there is stimulation at a time that corresponds to multiple overlapping chunks, the box was probably not behaving too well -- thats why such usage is now prevented.

Another thing is that since this is a replay scenario that you have a problem winh, if things are done properly with TCP Tagging (i.e. all components that render instructions to the user forward the instruction onset times directly to acquisition server and that are then read from there before recorded to a file), it cannot be assumed that the times coming from the lua stimulator match the times of the earlier run except perhaps approximately. In replay scenarios the stimulation markers should be read from the recorded file and not re-generated.

Hope this helps.

Cheers,
Jussi

FelixYan
Posts: 7
Joined: Wed Oct 23, 2019 9:11 am

Re: Tie Fighter Example - Getting Started

Post by FelixYan »

I wander if you fixed this cause I've been facing the same problem.

Also I tried to put the stim based e[oching before the time base epoching, I can only get the mean, the variance is still X.

Then I tried to build a new one inside using the stim base epoching, I used the time based epoching. Still have the same problem.

After this I put the stim based epoching back and both mean and variance are gone.

I'm really new to openvibe, it will be very helpful if some can answer why this happened.

regards,

Felix

Post Reply