Page 1 of 1

The Driver did not show the data in real time

Posted: Fri Mar 18, 2016 1:01 pm
by Hanjinky

I have created a OpenViBE driver for our own EEG amplifier and it worked successfully for a long time
However, recently there always is a delay when I receive data from the amplifier through the driver. The driver did not display the data in a real-time way as before, instead it seems to be stuck for 3 to 5s ,and then pump out data which could be easily noticed via the dark blue bar in the GUI of the driver or via the signal display toolbox in the designer.

But it did ont mean the driver skiped some data, the data seems to be completed because I got the right wave when I turned on the "square wave" mode for our amplifier. It also seems that the data has been sent to the platform in time because I made it report everytime after it was sent and the report seems right.
So,this situation really confuses me a lot and I don't know how to fix it.Could you please give me some help?


Re: The Driver did not show the data in real time

Posted: Fri Apr 01, 2016 8:06 am
by jtlindgren
Hi Hanjinky,

if this problem has appeared from updating from one openvibe version to another, it'd be necessary to first understand which version the driver worked properly in, and in which it stopped working. If its the same openvibe version, its a bit more difficult to understand where this could be suddenly coming from. Are the other drivers working normally, for example the artificial generators in the Acquisition Server?


Re: The Driver did not show the data in real time

Posted: Fri Apr 01, 2016 9:15 am
by Hanjinky
Dear Jussi

Thank you for your reply~
I did not do any updating since I succeeded in installing openvibe , because it took quite a long time for the installing . And the other drivers did work normally, in fact I had to make a new driver for another amplifer because of the problem and it worked normally.
I tired to built the wrong driver in the openvibe on another PC and the phenomena is just the same. I thought there may be some bugs in the code however I did not change anything after it worked successfully. So it is really strange.