impedance checking missing in EPOC driver - openvibe 1.1.0

Making & changing hardware drivers in Acquisition Server
Post Reply
Ramiro
Posts: 8
Joined: Tue Mar 17, 2015 4:19 pm

impedance checking missing in EPOC driver - openvibe 1.1.0

Post by Ramiro »

Hi,
I have updated OpenViBE to version 1.1.0 and the option to check the impedance is not found in Driver Properties as you have announced, but it does not appear in the preferences tab. What am I doing wrong?

I have the version 1.1.0 of OpenViBE running under Windows 10.

The question arises from the need to obtain the impedance value provided by the EPOC in real-time, in the RAW_CQ variable of the edk.dll driver. The following link explains some of its functionality:
https://emotiv.com/forum/messages/forum ... ssage16985

Can I do that?, because as I reading the documentation in Tutorial 4: Using the built-in impedance checker in part Update the impedance values (http://openvibe.inria.fr/tutorial-using ... e-checker/) specify that the IDriverContext function could be used only when the driver is not initialized and started.

Regards
Last edited by Ramiro on Mon Oct 05, 2015 6:23 pm, edited 3 times in total.

jtlindgren
Posts: 778
Joined: Tue Dec 04, 2012 3:53 pm
Location: INRIA Rennes, FRANCE

Re: impedance checking missing in EPOC driver - openvibe 1.1

Post by jtlindgren »

Hello Ramiro,

not all drivers support the impedance checking. Afaik our Emotiv driver doesn't. By driver we mean the glue/conversion code between openvibe and some manufacturer provided means to talk with the device. The device might support impedance checking, but nobody might have implemented the necessary glue.

You can relatively easily implement the impedance checking if you know how to get the info from the hardware AND if you can compile the driver (sometimes you need stuff from the manufacturers to do this, like an SDK). Since the doc you link is a bit old, the best reference to start might be to look at Generic Oscillator or some other driver code that already implements the impedance checking. There is also a bit of extra trouble in adding the button to the driver GUI's .ui file.

I'll try to update the old doc tomorrow.


Good luck,
Jussi

Post Reply