Emotiv EPOC driver status

Making & changing hardware drivers in Acquisition Server
Rapten
Posts: 22
Joined: Fri Apr 15, 2011 11:27 am

Re: Emotiv EPOC driver status

Post by Rapten »

I've have Emotiv Research Edition SDK v1.0.0.4-PREMIUM and the data displaying is still a problem.
I tried filtering and everything else but no success. when i try writing it in a CSV format the file contains the header and rest of it filled with -1.#QNAN0;. Any suggestions ?? :(

lbonnet
Site Admin
Posts: 417
Joined: Wed Oct 07, 2009 12:11 pm

Re: Emotiv EPOC driver status

Post by lbonnet »

Hi !
Is it normal to get warnings during compilation about conversion from double to float and possible data loss?
Yes. The headset produces float64 values converted in float32. The (static) cast is safe, so it shouldn't be a problem.
The headset works with the Emotiv software. No problems with the Expressiv suite.
Ok...
when i try writing it in a CSV format the file contains the header and rest of it filled with -1.#QNAN0;
Yes, that's the point. OpenViBE somehow receives wrong values. Not A Number values.

I just updated the emotiv driver. Please update your SVN repository, and rebuild the software.
I added some error checking/logging, plus debug messages.

In your configuration file (C:\Users\login\openvibe.conf or C:\Document And Settings\login\openvibe.conf), please add the following line :

Code: Select all

Kernel_MainLogLevel = Debug
And don't forget a linefeed at the end :)
If the file does not exist, please create it.

Then run the Acquisition-server, and use the Emotiv driver for some times (10-20 seconds).
You will see many messages in the console (Trace, Debug messages), e.g. drift correction messages. Don't pay attention to it :)
Stop the driver, disconnect it, exit the acquisition server.

Go in [openvibe]\dist\log. There should be a file named openvibe-acquisition-server.log.
Please send me that log file (attach to a post, or by private message... your choice), and I will check if the values sent by the Emotiv Engine are good or not, or if the API calls failed somehow.

Cheer up ! We will solve this !!

Laurent-
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !

Rapten
Posts: 22
Joined: Fri Apr 15, 2011 11:27 am

Re: Emotiv EPOC driver status

Post by Rapten »

openvibe-acquisition-server.log
(180.89 KiB) Downloaded 292 times
here is the log file. i had to shrink the size of this log file to fit to the upload limit.
Am i getting any data ?

lbonnet
Site Admin
Posts: 417
Joined: Wed Oct 07, 2009 12:11 pm

Re: Emotiv EPOC driver status

Post by lbonnet »

Thanks Rapten for the log,

The log messages in your file do not match the new massages I put in the code.
I assume you didn't update your SVN repository and/or re-compile the software ?

Laurent
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !

Rapten
Posts: 22
Joined: Fri Apr 15, 2011 11:27 am

Re: Emotiv EPOC driver status

Post by Rapten »

Hi Laurent,

I've updated the trunk and rebuilt the entire program. here is the new log file:
openvibe-acquisition-server.log
(17.41 KiB) Downloaded 285 times
I could see improvement in the updated version and wanted to know if you could figure out any thing from this log file. :)

here's a snapshot
No visualization.JPG
No visualization.JPG (93.21 KiB) Viewed 14018 times
as you can see the raw signals are visible now both the visualizations are not responding. what could be the problem..

regards.

jlegeny
Posts: 239
Joined: Tue Nov 02, 2010 8:51 am
Location: Mensia Technologies Paris FR
Contact:

Re: Emotiv EPOC driver status

Post by jlegeny »

Hello Rapten,

could you please show us the scenario which you are using ? In order for the map signal displays to work they have to have positions of the electrodes. You can find examples of scenarios using these displays in dist/share/openvibe-scenarios/box-tutorials

Cheers
Jozef

Mikas
Posts: 1
Joined: Fri Aug 26, 2011 5:04 pm

Re: Emotiv EPOC driver status

Post by Mikas »

Hi everyone

I still have problem with driver installation. After executed win32-build.cmd, I got "Install complete" message as in the attach picture, but for the last procedure when I looked in dist directory, there are no openvibe-acquisition-server.cmb file and when executed acquisition server there are still no emotiv on the list

I'm using Windows XP + VC++ 2008 and Emotiv Research Edition SDK_v1.0.0.4

Thanks in advance
Attachments
install.gif
install.gif (15.58 KiB) Viewed 13943 times

lbonnet
Site Admin
Posts: 417
Joined: Wed Oct 07, 2009 12:11 pm

Re: Emotiv EPOC driver status

Post by lbonnet »

Hello Mikas !

From the log you attached I can see that you are trying to build a branch in the acquisition server named wip-lbonnet-emotiv.
This branch was the work-in-progress version of the driver and has been removed on the 13th of September 2010.

Please take the latest version of the SVN, and follow the installation instructions.

As you are using Emotiv Research Edition SDK_v1.0.0.4 and the default configuration search for SDK v1.0.0.3, you may have to change the path where the build script looks at, as stated in the FAQ.
Open cmake-modules/FindThirdPartyEmotivAPI.cmake. Modify the FIND_PATH call with your actual path to the emotiv SDK.
This line (a bit explained here):

Code: Select all

FIND_PATH(PATH_EmotivAPI edk.h  PATHS 
    # for windows XP:
    "C:/Program Files/Emotiv/Emotiv Development Kit_v1.0.0.3-PREMIUM" 
    "C:/Program Files/Emotiv Development Kit_v1.0.0.3-PREMIUM" 
    "C:/Program Files/Emotiv/Emotiv Development Kit_v1.0.0.3-PREMIUM/doc/examples/include" 
    "C:/Program Files/Emotiv Development Kit_v1.0.0.3-PREMIUM/doc/examples/include" 
    # for windows 7 64b:
    "C:/Program Files (x86)/Emotiv/Emotiv Development Kit_v1.0.0.3-PREMIUM" 
    "C:/Program Files (x86)/Emotiv Development Kit_v1.0.0.3-PREMIUM" 
    "C:/Program Files (x86)/Emotiv/Emotiv Development Kit_v1.0.0.3-PREMIUM/doc/examples/include" 
    "C:/Program Files (x86)/Emotiv Development Kit_v1.0.0.3-PREMIUM/doc/examples/include" 
    $ENV{OpenViBE_dependencies})
should be modified by adding the path to your Emotiv SDK in the same way. For example:

Code: Select all

FIND_PATH(PATH_EmotivAPI edk.h  PATHS
    "C:\Program Files\Emotiv Research Edition SDK_v1.0.0.4-PREMIUM" 
    "C:\Program Files\Emotiv Research Edition SDK_v1.0.0.4-PREMIUM/doc/examples/include"
    $ENV{OpenViBE_dependencies})
hope this helps.

Laurent
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !

etwas
Posts: 1
Joined: Sat Oct 29, 2011 7:50 pm

Re: Emotiv EPOC driver status

Post by etwas »

Hi,
Any Emotiv EPOC driver news with developer SDK?
I try to work with OpenViBE and the SDK....let me know any solutions for it ASAP.
thanks!!

lbonnet
Site Admin
Posts: 417
Joined: Wed Oct 07, 2009 12:11 pm

Re: Emotiv EPOC driver status

Post by lbonnet »

Hi etwas,

The developer SDK does not give access to the raw EEG data coming from the headset.
Only the Research SDK (and superior versions) allows that for the moment.

The OpenViBE driver for Emotiv EPOC has been developed and released officially after some discussion with Emotiv staff.
It's only compatible with the Research SDK, and on our side we don't expect any change in near future.

Laurent-
Follow us on twitter >> openvibebci

Checkout my (old) blog for some OpenViBE tips & tricks : here !

Rodel
Posts: 1
Joined: Tue Jan 31, 2012 11:09 am

Re: Emotiv EPOC driver status

Post by Rodel »

Hi everybody,

this is my first post in the topic. I've read all posts before, but I've got doubts.

I'm student and freelance developer. I adquired the developer license of EPOC Emotiv, version 1.0.0.0. I would like to know if somebody could send me the driver that all of you say works perfectly, or how can I get it.

In my system, I configure the adquisition server with my driver and when I make a click over "Play", the system cracks with the message "OpenViBE-adquisition-server-dynamic.exe left works".

Thanks in advance and sorry for my improved english ;)
Greetings,
Rodel (jmrodel.zero@gmail.com)

PS: If would be possible, I'd appreciate if somebody could give me some instructions (links) to make the driver (I don't know how difficult could be).

jlegeny
Posts: 239
Joined: Tue Nov 02, 2010 8:51 am
Location: Mensia Technologies Paris FR
Contact:

Re: Emotiv EPOC driver status

Post by jlegeny »

Hello Rodel,

in order to capture the raw EEG from the Emotiv EPOC headset (which is necessary in order to use OpenViBE with this headset) you will need to have the Research Edition of the SDK.

Regards
Jozef

omid20d100
Posts: 1
Joined: Wed Jul 25, 2012 5:46 pm

Re: Emotiv EPOC driver status

Post by omid20d100 »

Hi everybody,
how can i edit "electrode localization file reader" for Emotiv Epoc?
does anyone do this?
please help me.

yrenard
Site Admin
Posts: 645
Joined: Fri Sep 01, 2006 3:39 pm
Contact:

Re: Emotiv EPOC driver status

Post by yrenard »

Hello omid20d100,

This box is not specific to the cap/device you are using. Actually none of the OpenViBE boxes are specific to the cap/device you are using. However, this box uses a text datafile with a list of electrodes localisation. So depending on what you want to achieve, you can either look at the source code of the box in openvibe-plugins/file-io/trunc/src or edit the text file with electrode information !

Best regards,
Yann

toncho11
Posts: 120
Joined: Tue Apr 19, 2011 7:58 pm

Re: Emotiv EPOC driver status

Post by toncho11 »

There is an official Linux research kit from Emotiv now!

http://emotiv.com/forum/forum3/topic2295/#message13452

I was able to download it.

We need to write an OpenVibe driver for it though.

It works. I could acquire raw signal on Linux. It also comes with some code samples that can be used for building a driver I believe.

-Anton

Post Reply