Issues with classifier processor box running p300 speller

Concerning processing components: filters, file load/save, visualizations, communication ...
Post Reply
blewandowski
Posts: 6
Joined: Sun Feb 07, 2021 12:27 pm

Issues with classifier processor box running p300 speller

Post by blewandowski »

Hi,

I'd like to start of with a thank you for such a great resource, after a bit of a trouble building the application I was able to start the designer and data collector without any problems.

I wanted to run the P300 demo, to see how well a simple setup will work, and was able to run all steps up until the online step.

The classifier was trained successfully with cross validation accuracy at 80%. Here are the full logs

Code: Select all

[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Received train stimulation. Data dim is [1440x225]
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> For information, we have 240 feature vector(s) for input 1
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> For information, we have 1200 feature vector(s) for input 2
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> k-fold test could take quite a long time, be patient
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Finished with partition 1 / 5 (performance : 81.944444%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Finished with partition 2 / 5 (performance : 79.861111%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Finished with partition 3 / 5 (performance : 79.166667%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Finished with partition 4 / 5 (performance : 82.291667%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Finished with partition 5 / 5 (performance : 79.861111%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Cross-validation test accuracy is 80.625000% (sigma = 1.250000%)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Cls vs cls      1     2
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Target  1:   10.0  90.0 %, 240 examples
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Target  2:    5.2  94.8 %, 1200 examples
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer> Training set accuracy is 85.972222% (optimistic)
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Cls vs cls      1     2
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Target  1:   23.8  76.2 %, 240 examples
[ INF ] At time 606.273 sec <Box algorithm::(0x0a5a6a4a, 0x1d92a778) aka Classifier trainer>   Target  2:    1.6  98.4 %, 1200 examples
[ INF ] At time 0.000 sec <Box algorithm::(0x000000ea, 0x000057a1) aka Launch> Lua script terminated
Running the online part though, does not suggest letters as I would have expected. I do find an odd log message

Code: Select all

[ WARNING ] Box <Classifier processor> sends inconsistent chunk dates on output [0] (current chunk dates are [98972436677,101549417054] whereas previous chunk dates were [0,0])
[ WARNING ] 'Stimulations' streams should have continuously dated chunks
[ WARNING ] Please report to box author and attach your scenario
Any ideas what this might be?
Thank you in advance for any tips on the matter.
Cheers!

Thomas
Posts: 69
Joined: Wed Mar 04, 2020 3:38 pm

Re: Issues with classifier processor box running p300 speller

Post by Thomas »

Hi,

Indeed a bug was found on the P300 speller.

A fix has been applied to the development branch, so if you have already built OpenViBE yourself, you need to:
- Checkout development branch on all repositories (meta, sdk, designer and extras).
- Run install_dependencies script again
- build.

Then you will have a version of OpenViBE with the fix.

Next OpenViBE release will also contain that fix.

All the best,
Thomas

4emmaliz
Posts: 1
Joined: Tue Jul 20, 2021 8:34 pm

Re: Issues with classifier processor box running p300 speller

Post by 4emmaliz »

Hi,

I was also having this bug on the Magic Card scenario. Was this fixed for this scenario as well as the speller?

In response to this thread, I tried building the newest source: openvibe-3.1.0
On two different computers, one of which I have 3.0 successfully built on, I receive the same error in regard to "...Cannot open include file: 'pthread.h': No such file of directory..." in the CMakeError file.

Code: Select all

Determining if the include file pthread.h exists failed with the following output:
Change Dir: E:/opv31/build/sdk-x64/CMakeFiles/CMakeTmp

Code: Select all

  CheckIncludeFile.c

E:\opv31\build\sdk-x64\CMakeFiles\CMakeTmp\CheckIncludeFile.c(1): fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory [E:\opv31\build\sdk-x64\CMakeFiles\CMakeTmp\cmTC_9d7a2.vcxproj]



One difference from when I've built previous versions is that 7-zip has one error every time I use it to expand 3.1 source.

Thank you!

Thomas
Posts: 69
Joined: Wed Mar 04, 2020 3:38 pm

Re: Issues with classifier processor box running p300 speller

Post by Thomas »

Hi,

There is indeed an issue with the sources archive. I will fix it ASAP.

In the meantime, you can get the sources from the Inria gitlab. You can find instructions here: http://openvibe.inria.fr/repo-instructions/

Cheers,
Thomas

Post Reply