Matlab: large lag when sending stimulation codes

Concerning processing components: filters, file load/save, visualizations, communication ...
Post Reply
Nico A.
Posts: 8
Joined: Thu Mar 07, 2019 8:05 am

Matlab: large lag when sending stimulation codes

Post by Nico A. »

Hi, I am using a Matlab box to send stimulations, but there is a large gap between the Event and the time point when the stimulation is sent (approx. 200 ms). Is this normal?

I read in the following site that some lag is to be expected with stimulations via the Matlab Scripting box:
http://openvibe.inria.fr/overview-sendi ... -openvibe/

However, 200 ms seems like a lot. I also could not solve the problem with lowering the box clock frequency.

Thibaut
Posts: 144
Joined: Wed Oct 31, 2018 9:14 am

Re: Matlab: large lag when sending stimulation codes

Post by Thibaut »

Matlab is a heavy language, not really done for optimization and real time. Python would be "maybe" faster.

Nico A.
Posts: 8
Joined: Thu Mar 07, 2019 8:05 am

Re: Matlab: large lag when sending stimulation codes

Post by Nico A. »

Thank you for the answer!
Right now I'm trying the figure out how the "external processing" box works; are there example Scenarios with external processing boxes that call a script rather than an executable? I always receive the error "No Client connected before the timeout."

edit: another question: why is there no Python Scripting box in my Version of OpenVibe Designer 2.2.0? Is it maybe because it has become obsolete and is replaced by the External Processing box?

Thibaut
Posts: 144
Joined: Wed Oct 31, 2018 9:14 am

Re: Matlab: large lag when sending stimulation codes

Post by Thibaut »

It's weird for the python box, it is always present normally, you miss other boxes?

Nico A.
Posts: 8
Joined: Thu Mar 07, 2019 8:05 am

Re: Matlab: large lag when sending stimulation codes

Post by Nico A. »

The Matlab Scripting box is there. In the Folder "Scripting" there are the following boxes:

DLL Bridge
External Processing
Lua Stimulator
Matlab Scripting

When I type "python" in the search field (boxes) I get no results.

Thibaut
Posts: 144
Joined: Wed Oct 31, 2018 9:14 am

Re: Matlab: large lag when sending stimulation codes

Post by Thibaut »

Have you the correct python install (2.7 & 3.4 x64 if your openvibe is compile in 64 x32 if your openvibe is compile in 32)

Nico A.
Posts: 8
Joined: Thu Mar 07, 2019 8:05 am

Re: Matlab: large lag when sending stimulation codes

Post by Nico A. »

I tried installing Python 3.4.4 64 bit and reinstalled OpenVibe 64 bit. But there is still no Python Scripting box :(

Thibaut
Posts: 144
Joined: Wed Oct 31, 2018 9:14 am

Re: Matlab: large lag when sending stimulation codes

Post by Thibaut »

Hi,
When you launch OpenViBE what is the log on the console wndows (the black windows) ?
Thibaut

Post Reply