OpenViBE forum

The OpenViBE community
It is currently Sun Mar 24, 2019 8:42 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: SSVEP detection problem
PostPosted: Tue Dec 18, 2018 10:08 am 
Offline

Joined: Thu May 12, 2016 10:51 am
Posts: 2
Within the scope of my university studies we have build a one-channel EEG system based on OpenEEG work with the purpose of showing the students the capabilities of BCI. The device was tested using lab equipment and have shown that it is able to register the faint brain signals successfully. Then we started with experimental part. The set up is very basic, three electrodes are used to detect the EEG signals (Oz, A2 and FPz region). First bunch of experiments while testing the device were targeted on obtaining an Alpha wave and registering Alpha wave blocking by opening one's eyes. These experiments have shown very good results, demonstrating the signal amplitude and the frequency within normal range according to the studies.
As a next step the SSVEP detection was performed using OpenViBE software and default settings of SSVEP scenario (a shooting game). However, no SSVEP was detected in none of the experimental set ups. Power spectrum does not show the target frequency (8, 12, 25, 20Hz consequently tested) and no results are obtained. It seems like it just cannot register the SSVEP signals. It seems improbable while the Alpha wave detection is very successful.
I have searched through papers and could not find in any of it the reason why the SSVEP may not be registered on the first place (the closest I could get is what may influence the accuracy of the SSVEP, but in our case it is not helping). I'm desperate looking for an answer and will be very grateful if someone could advice what could be potential reasons for not being able to detect the SSVEP and realize the scenario.
I can provide any additional info on the matter if someone is willing to support.
Thank you very much!


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 6:55 pm 
Offline

Joined: Tue Dec 04, 2012 3:53 pm
Posts: 777
Location: INRIA Rennes, FRANCE
Hi Valeria, if you know any electrical engineeers, you could combine a sinusoidal signal generator (a device) to a physical phantom or directly to the electrodes. By controlling the frequency on/off physically you could try to debug the pipeline. Its a bit difficult if you dont know whats in the data. Alternatively you could use signal generators in OV and modulate their results to make artificial data.

The key to debugging usually involves checking input and output of every component (in ov, the boxes) makes sense and is whats expected.

Cheers,
Jussi


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Americanized by Maƫl Soucaze.