openvibe 2.2 installation in Raspberry Pi 3 Model B+

Come here to discuss about OpenViBE in general!
Post Reply
jeban83
Posts: 7
Joined: Tue Feb 19, 2019 8:15 am

openvibe 2.2 installation in Raspberry Pi 3 Model B+

Post by jeban83 »

Appreciate if anyone can throw some insight into how to install openvibe 2.2 in Raspberry Pi 3 Model B+ running Raspbian OS.

Thibaut
Posts: 226
Joined: Wed Oct 31, 2018 9:14 am

Re: openvibe 2.2 installation in Raspberry Pi 3 Model B+

Post by Thibaut »

Hi,
it will have been long, but I found someone who had already succeed to compile on Raspbian an old version of openvibe (1.2.2).
On extra/CMakeLists.txt and sdk/CMakeLists.txt
comment with à # the line

Code: Select all

SET(OV_EIGEN_FLAGS "-msse2")
He disable an optimization
in extra/application/demos/CMakeLists.txt
comment the line

Code: Select all

OV_ADD_PROJECTS("APPLICATIONS_DEMOS")
He disable demos applications
He change an other thing for dependencies but they have change a lot since this old version.

jeban83
Posts: 7
Joined: Tue Feb 19, 2019 8:15 am

Re: openvibe 2.2 installation in Raspberry Pi 3 Model B+

Post by jeban83 »

Hi,
Thanks for the response but this did not help. Getting the same error:

Compiling lsl ...
cp: cannot stat 'liblsl/build/src/liblsl.so': No such file or directory
Running extras/scripts//linux-dep-helpers//linux-compile-vrpn.pl ...
Compiling vrpn ...
cp: cannot stat 'vrpn/quat/pc_linux64/*.a': No such file or directory
cp: cannot stat 'vrpn/pc_linux64/*.a': No such file or directory
Running extras/scripts//linux-dep-helpers//linux-compile-itpp.pl ...
OpenViBE SDK dependencies were successfully installed

Any guidance,

Thanks

thunfisch96
Posts: 7
Joined: Wed May 12, 2021 2:27 pm

Re: openvibe 2.2 installation in Raspberry Pi 3 Model B+

Post by thunfisch96 »

Hi,

Got the same error:

Code: Select all

Running extras/scripts//linux-dep-helpers//linux-compile-vrpn.pl ...
Compiling vrpn ...
cp: cannot stat 'vrpn/quat/pc_linux64/*.a': No such file or directory
cp: cannot stat 'vrpn/pc_linux64/*.a': No such file or directory
Did you solve the problem?

Thomas
Posts: 67
Joined: Wed Mar 04, 2020 3:38 pm

Re: openvibe 2.2 installation in Raspberry Pi 3 Model B+

Post by Thomas »

Hi,

The error you are showing is from the dependencies install script.
There seem to be a problem with vrpn and lsl libs.

The install dependencies scripts downloads archives of lsl and vrpn, uncompresses them and builds them. Compilation seems to have failed since your log shows that the .so and .a files could not be found.

The script dealing with VRPN is extras/scripts/linux-dep-helpers/linux-compile-vrpn.pl.
The script is configuring the Makefiles of VRPN before building it. And it is not doing it for an ARM architecture.
Before you modify the script, remove the previously modified folders dependencies/arch/vrpn.
You can modify the script this way:
- remove lines 29 to 47
- replace with the two following lines:
system('sed -i "s/#HW_OS := pc_linux$/HW_OS := pc_linux_arm/g" vrpn/quat/Makefile');
system('sed -i "s/#HW_OS := pc_linux$/HW_OS := pc_linux_arm/g" vrpn/Makefile');
- Run install-dependencies.sh again.
- If there is still an issue, you can look at the build logs in dependencies/arch/vrpn/make-vrpn.log and dependencies/arch/vrpn/quat/make-quat.log

The script dealing with LSL is extras/scripts/linux-dep-helpers/linux-compile-lsl.pl.
It doesn't do any architecture specific work. You can look at the build logs which are dependencies/arch/LSL/liblsl/build/make-liblsl.log and dependencies/arch/LSL/liblsl/build/cmake-liblsl.log to find more about what went wrong.

Hope this helps. Let us know what you find and how you get on.

Cheers,
Thomas

Post Reply