Search found 780 matches

by jtlindgren
Wed Aug 01, 2018 7:20 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

Thanks for the report! Its difficult to support multiple simultaneous timestamps due to the boxes design where there can be one stim per one sample. I suggest simply modifying the stimulus generator to have sufficient delays. But actually this makes me realize that instead of checking for timestamp ...
by jtlindgren
Tue Jul 31, 2018 7:34 am
Forum: Scenarios and BCI design
Topic: OpenVibe SSVEP-bci-training-acquisition - window not shown
Replies: 3
Views: 1575

Re: OpenVibe SSVEP-bci-training-acquisition - window not sho

Hello Haodong, it seems you wanted to write a reply but it seems you posted a separate message. To give a bit of context, could you copy paste the original thread link and I'll take a look?

Cheers,
Jussi
by jtlindgren
Tue Jul 31, 2018 7:31 am
Forum: Discussion about OpenViBE
Topic: Stimulation Codes for Motor Imagery
Replies: 3
Views: 4555

Re: Stimulation Codes for Motor Imagery

Hello, 33284 is the end of file code. Its possible that the other numbers are some custom codes introduced by the experimenter. If the dataset documentation doesn't describe this, the only possible recourse seems to be to contact the dataset authors (see the referred scientific paper). However, its ...
by jtlindgren
Mon Jul 30, 2018 12:39 pm
Forum: Discussion about OpenViBE
Topic: [STICKY] Videos -- Uses of OpenViBE
Replies: 1
Views: 6873

Re: [STICKY] Videos -- Uses of OpenViBE

It seems that since the original post, more videos have kept appearing! You can browse them with youtube search.


Cheers,
Jussi
by jtlindgren
Mon Jul 30, 2018 11:14 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

Hi, the gipsa lsl box source code is under extras/contrib/. Thanks to your report, I found out that the box can indeed have some problems synchronizing the signal and stimulation streams, and that sometimes it'll never pass out the stimulations. This morning I made a fix attempt for the problem. Can...
by jtlindgren
Fri Jul 27, 2018 2:08 pm
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

If I connect "Sinus Oscillator" and "Clock Stimulator" to LSL Export GIPSA, the result is that the LSL signal stream will have +1 signal channel, and I see the stimulations that the clock stimulator generates there as float numbers on that extra channel. When there is no stimulation, the value is 0....
by jtlindgren
Fri Jul 27, 2018 8:34 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

Hi, I'm trying to figure out whats the problem here. Do you in some circumstances have two acquisition servers running at the same time? These should have at least two ports different from each other: the client port (normally 1024) and the tcp tagging port (normally 15361). However, the latter will...
by jtlindgren
Thu Jul 26, 2018 10:49 am
Forum: Scenarios and BCI design
Topic: How to make the motor imagery CSP work ?
Replies: 3
Views: 2071

Re: How to make the motor imagery CSP work ?

Hi Kiyarash, a few suggestions, 1) collect train data twice, train with first, use the second file as test. this rules out optimism in the cross validation as well as possible feedback effects in online (bad results may make you do even worse). The accuracies on the second set are more indicative of...
by jtlindgren
Thu Jul 26, 2018 7:15 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

If you really want to use the gipsa box, I imagine the box will work correctly if it gets proper signal in one input and stimulations in the other. Can you try that? The design philosophy of the gipsa box likely is to have the stimulations aside the signal. If you use the other box, yes you'll have ...
by jtlindgren
Tue Jul 24, 2018 9:04 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

Ok, thinking about your report, is the problem because the stimulations are exactly at the same time? Since the gipsa box is using a signal channel to transmit the stimulations, maybe its just not possible to put two numbers in one slot. To get around this, you can either use the non-gipsa box or ad...
by jtlindgren
Tue Jul 24, 2018 8:46 am
Forum: Boxes
Topic: LSL Export (Gipsa) - Weird issue with lost markers
Replies: 13
Views: 4009

Re: LSL Export (Gipsa) - Weird issue with lost markers

Hi, I can investigate if there's a bug in the box, but what you are doing should not be done in general. Please read http://openvibe.inria.fr/tcp-tagging/ In short, if you have stimulations generated by a box and have some rendered events corresponding to them, and expect to somehow analyze the EEG ...
by jtlindgren
Thu Jul 19, 2018 8:57 am
Forum: Box and application development
Topic: Display a new box
Replies: 5
Views: 3950

Re: Display a new box

Hi, when you start Designer, it loads the .dll's containing boxes. These dlls should be in the bin/ directory. When a dll is loaded, different algorithms, boxes and types that the dll contains will be registered to the kernel by the directives in the main .cpp of the dll (that should also print the ...
by jtlindgren
Mon Jul 16, 2018 7:39 am
Forum: Acquisition server and drivers
Topic: g.tec usbamp drivers
Replies: 1
Views: 1715

Re: g.tec usbamp drivers

Hi, you need to download the operating system driver from gtec. Once you can acquire data with the gtec gusbamp demo tool, it should work with AS as well. The file is called something like

g.USBamp_Driver_3.14.00_Win64.zip

Cheers,
Jussi
by jtlindgren
Thu Jul 12, 2018 11:12 am
Forum: Box and application development
Topic: Display a new box
Replies: 5
Views: 3950

Re: Display a new box

Hi, sorry, didn't notice the original message. What system are you building on? The first thing I'd check is if your thing is built/included at all. Very elementary is to have the folloming in the ovp_main.cpp OVP_Declare_Begin() printf("Hello I AM HERE!\n"); OVP_Declare_End() If you don't have that...
by jtlindgren
Thu Jul 12, 2018 9:21 am
Forum: Discussion about OpenViBE
Topic: A new tutorial on BCI paradigms
Replies: 1
Views: 4194

A new tutorial on BCI paradigms

Dear forumers, I just wrote a new brief tutorial summarizing on a high level what is different in the different BCI paradigms (p300,ssvep,motor imagery,neurofeedback) in OpenViBE. I hope the community finds the summary useful. http://openvibe.inria.fr/tutorial-level-1-choosing-the-bci-paradigm/ If y...